Exception has been thrown by target of invocation

Hi I would like to merge 2 datatables by a primary key
but 1 of the assign primary key activities keep throwing exception

1 Like

cause of this exception is another exception which occurred inside the method being invoked. please have look into Merge SFO and register Data, if you are using this just to merge two data table you can also use merge Table activity.

1 Like

But the exception source shows that the exception happened before invoke method activity at Assign SFODt.Primary Key = New DataColumn() {SFODt.Columns(“Staff ID”)}.

I’m sure that the column exists, because the step before was a Dt.Select to filter via that specific column. Apart from this, I don’t know what else could have caused an exception?

still no help on this front…
I was thinking either the table has duplicate primary key or does not have the column name that I assigned as primary key, but ive checked both and still.
The same error would persist even if i use merge datatable because the error is with assigning primary key.

Did you check if the Staff ID column has any null values?


This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.