Exception from HRESULT: 0x8001010A - Issue with Outlook message

Hi everyone

For a long period of time my error handling have been pushing this error out, when trying to send an status e-mail in the background. The workflow is running after counting different processes and then send an e-mail with the information.

I have searched in several forums and cant seem to find a solution. So I hope some of you experienced people have an idea, where to look.

I know that the message filter says that the program is occupied in some way. But can I do anything to avoid getting this error? I have my doubt if its UiPath related or an Office related error.

You can find the full Exception below:

System.SystemException: Meddelelsesfilteret indikerer, at programmet er optaget. (Exception from HRESULT: 0x8001010A (RPC_E_SERVERCALL_RETRYLATER)) —> System.Runtime.InteropServices.COMException: Meddelelsesfilteret indikerer, at programmet er optaget. (Exception from HRESULT: 0x8001010A (RPC_E_SERVERCALL_RETRYLATER))
at Microsoft.Office.Interop.Outlook.ApplicationClass.get_Version()
at UiPath.Mail.OutlookAPI.InitOutlook()
— End of inner exception stack trace —
at UiPath.Executor.WorkflowRunner.EndExecute(IAsyncResult result)
at UiPath.Core.Activities.InvokeWorkflowFile.EndExecute(AsyncCodeActivityContext context, IAsyncResult result)
at System.Activities.AsyncCodeActivity.System.Activities.IAsyncCodeActivity.FinishExecution(AsyncCodeActivityContext context, IAsyncResult result)
at System.Activities.AsyncCodeActivity.CompleteAsyncCodeActivityData.CompleteAsyncCodeActivityWorkItem.Execute(ActivityExecutor executor, BookmarkManager bookmarkManager)

I don’t think whether this one is with the UiPath robot as you are getting the error after running the uipath robot. Just make sure the application is running and it is free to make any changes in that. As I found, the error states the application is busy, make sure the application is not running another time in the background @MartinLorange

Just check the same in Task Manager

Thank you for your reply.

I will have a closer look at that. I have already tried closing/killing outlook before it sends the mail, but it still throws the error.

Have a great day :slight_smile:

Is it working if you send the mail using the mail activity individually? @MartinLorange

Hi @ MartinLorange,

Exception from HRESULT: 0x8001010A…It means what it says - the app you are calling (Outlook) is busy and the COM system timed out waiting for it. You need to retry later.

Yeah, I figured that out. I guess its related to Windows/Outlook, even though i kill the app before using mail activity in UiPath it still throws this error from time to time.

So it was more if anyone knew a workaround or anything like that.

Thank you for taking time to reply @Luis261980 :slight_smile:

Hi everybody!

In fact I’m getting the same error with Word application.
I have tried killink the process before calling it, but sometimes it gets busy and some other times it don’t.

Maybe it takes it´s time to kill the process accordingly since it seems more like a WINDOWS issue rather than UIPath’s. I’m thinking, what if we also try to manually kill the process in the Task Manager? Haven’t tried it yet, but may be worth a shot, at least for testing purposes.