Exception Error

I keep getting these recently and im not sure why

Info: The underlying connection was closed: The connection was closed unexpectedly.

RemoteException wrapping System.Exception: The underlying connection was closed: The connection was closed unexpectedly. ---> RemoteException wrapping System.AggregateException: One or more errors occurred. ---> RemoteException wrapping System.Net.WebException: The underlying connection was closed: The connection was closed unexpectedly.
at UiPath.Core.Activities.Orchestrator.RetryHandler.d__5.MoveNext()
--- End of stack trace from previous location where exception was thrown ---
at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task)
at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
at UiPath.Core.Activities.Orchestrator.HttpLoggingHandler.d__2.MoveNext()
--- End of stack trace from previous location where exception was thrown ---
at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task)
at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
at System.Net.Http.HttpClient.d__58.MoveNext()
--- End of stack trace from previous location where exception was thrown ---
at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task)
at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
at UiPath.Core.Activities.Orchestrator.HttpClientService.d__1.MoveNext()
--- End of inner exception stack trace ---
at System.Threading.Tasks.Task.ThrowIfExceptional(Boolean includeTaskCanceledExceptions)
at System.Threading.Tasks.Task`1.GetResultCore(Boolean waitCompletionNotification)
at System.Threading.Tasks.Task`1.get_Result()
at UiPath.Core.Activities.BaseQueueActivity.EndExecute(NativeActivityContext context, IAsyncResult result)
--- End of inner exception stack trace ---
at System.Activities.Statements.Throw.Execute(CodeActivityContext context)
at System.Activities.CodeActivity.InternalExecute(ActivityInstance instance, ActivityExecutor executor, BookmarkManager bookmarkManager)
at System.Activities.ActivityInstance.Execute(ActivityExecutor executor, BookmarkManager bookmarkManager)
at System.Activities.Runtime.ActivityExecutor.ExecuteActivityWorkItem.ExecuteBody(ActivityExecutor executor, BookmarkManager bookmarkManager, Location resultLocation)

Hi Jersey,

Are you getting this error when running bot or when you are trying to connect studio/robot to orchestrator? Could you please explain when exactly you are getting this error?

Sorry

When the bots are running, looking at logs its to do with either getting a new transaction or setting a transaction status

Bots run on Azure VM’s and its never a specific one

Using Orchestrator Cloud, I know that was really glitchy getting logged in this morning, but this has been happening for the last couple of weeks now

You can try following things -

  1. Check License allocation
  2. Disconnect your bots and reconnect (If they auto provisioned, try shutting down VM and restart)
  3. Check Bot account rights
  4. It could be Certificate as well, check if that’s not expired (Although, it usually comes in error logs)

Hope this solve your issue :smiley:

Every thing is ok, been running this for almost a year now and only just started getting this error,