Error while trying to run a Training Pipeline - AI Center

Hello everyone,

I’m working with AI Center and Document Understanding. I’m trying to run a training pipeline and It’s always failing no matter the Dataset I use. The exception I get is the one shown below:

Exception: Document type default not valid, check that document type data is in dataset folder and follows folder structure.

I’m following these steps in order to run the pipeline:

  1. Uploaded 11 PDF files as a Dataset
  2. Created a Data Labeling Session just to extract 6 fields from all the documents, I uploaded again all the 11 PDF that I uploaded before as a Dataset. After I finished the labeling process, I proceeded to export the files with the “All labelled” option.

    As you can see in the image below, in the Dataset was created a new folder call “export”
  3. I created an ML Package based on the “Document Understanding” OOTB model.
  4. When I try to run the Pipeline I always get the same error. I’ve tried selecting the parent folder, the “export” subfolder and even the subfolders contained in the “export” subfolder but I’m still unable to run a successful Pipeline.

Thank you all for your time and help.

Best regards

Hello @Jorge_Valbuena!

It seems that you have trouble getting an answer to your question in the first 24 hours.
Let us give you a few hints and helpful links.

First, make sure you browsed through our Forum FAQ Beginner’s Guide. It will teach you what should be included in your topic.

You can check out some of our resources directly, see below:

  1. Always search first. It is the best way to quickly find your answer. Check out the image icon for that.
    Clicking the options button will let you set more specific topic search filters, i.e. only the ones with a solution.

  2. Topic that contains most common solutions with example project files can be found here.

  3. Read our official documentation where you can find a lot of information and instructions about each of our products:

  4. Watch the videos on our official YouTube channel for more visual tutorials.

  5. Meet us and our users on our Community Slack and ask your question there.

Hopefully this will let you easily find the solution/information you need. Once you have it, we would be happy if you could share your findings here and mark it as a solution. This will help other users find it in the future.

Thank you for helping us build our UiPath Community!

Cheers from your friendly

Hi, please help.

Thanks @Pablito

I’ve found a post with an answer that helped me resolve the issue:

There is in fact an specific set of folders that has to be there in order to run a successful Pipeline, the error was that this set of folder were in one level below the expected for the Pipeline so It always failed.

That is correct, sorry for delayed response.

Also, btw, the initial upload of the PDFs in the dataset was useless. Only the export from the DM session matters, and that is the folder inside the export folder.


This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.