Error on invoke method: import row not correct format couldn't store <>

recently learned how to use the invoke method importrow to process and append a datarow to a datatable.

i am getting the following erro
message: input string was not in a correct format.couldn’t store < > in a Patient Cell Column. expected type is decimal

exception type:system.argumentexception

patient cell column is the name of a column and it is a decimal type. from my reading this error means that datarow being appended is blank on this column.

how do i pass this blank cell through the invoke method import row activity without erroring out? how should i handle this? being blank is intentional and i would like to keep the cell blank since not every row will have a cell phone number.


@Jason_Dossett - You may need to share some examples because I’m not sure what exactly you’re trying to do.

Did you try using the “Add Data Row” Activity?

i did but was not working do to i believe some quirk in the nested for each statments and my datatable setup. i spent about 4 hours yesterday and it kept telling me that the row already belonged to another table, even when i assigned variables as go betweens.

the current section works like this
i run a for each on dtNewPatients, each row has a dozenish columns
for each row i access a web page and pull the patient name and trim it, var_trimName, and var_wholeName
i enter the name on the page
the page brings up a table of names
i scrape the names into dtScrapedNames
i then do a for each name on dtScraped Names
then i run a for each on dtScraped Name
then i use a series of IF statements to var_wholeName and var_trim name. against dtScrapedName or no match at all.
here is the invoke method. i then want to copy over the entire current row from dtNew_patients onto one of 3 datatables based on a whole match, partial match, or no match.

and that is where i run into the above error.

the datatables will be written to CSV files for later use

Can you check the parameters you are passing to the invoke method and see if they are matching or not?


1 Like

I altered the data the workflow started with so that the first and second row it processes has data in the “cell phone” cell. worked without an issue.

currently i am using generate table to create a table off of a data sample and the cell phone column is a “decimal” type. looking online i am not finding any real way to get around this error except for one guy who simply changed his column formatting. so i am going to try that. empty cells are necessary and a requirement to work.

Cant you just check the data in the row before importing. If cell is empty just assign it 0

i could and if this were a one off thing you would be very correct and that would be the better idea, but i use the exact same data table structure at least 6 times in the first half of this workflow so i might as well build the database in a way that doesn’t require me to put in extra steps every time i want to copy the rows back and forth. also i need it to remain blank, and a 0 there would just require more steps in multiple places as i type the cell phone number quite a lot.

Can you share your workflow