Error Message: Unable to cast COM object of type


We deployed a process to a team and for some reason one specific user is getting the below error:

com error

Does anyone know how to fix? We’ve already tried reinstalling Microsoft office.


Can you check is there any version incompatibility? If so you can downgrade / Upgrade the excel activities package

Hope this helps


Its seems the issue is for microsoft outlook and not excel.

In any case how would i check if there are any version incompatibility?

@Asanka I am not quite sure if this works. But a simple search in Google resulted in this topic where they seemed to have solved the same kind of problem. Not sure if this is going to be of much help, but you can try it.

Hy @Asanka,

Try using the “Kill Activity: Excel” , prior running the Excel Application Scope activity, I have faced this issue a couple of times

Please let me know if it works.


Hey so its an outlook issue, not excel.

Hy @Asanka,

Could you share some more detalis on your workflow. In what activity are you getting this error?


Its trying to send and email in outlook. Once it gets to the send outlook email activity it breaks