Error in installation uipath.microsoftoffice365.activities

Good morning,
I use the community edition

From Manage Packages I try to install UiPath Microsoft Office 365, ver. 2.0.1
Unfortunately it always gives me this error:
"The following package(s) can not be installed: UiPath.MicrosoftOffice365.Activities 2.0.1

“Cannot load assembly: C:\Users\Oscar.nuget\packages\UiPath.microsoftoffice365.activities\2.0.1\lib/net6.0-windows7.0/UiPath.MicrosoftOffice365.Activities.Design.dll : System.IO.FileNotFoundException: Could not load file or assembly ‘UiPath.Platform, Version=, Culture=neutral, PublicKeyToken=null’. Impossibile trovare il file specificato.
File name: ‘UiPath.Platform, Version=, Culture=neutral, PublicKeyToken=null’
at System.Reflection.RuntimeAssembly.GetExportedTypes()
at UiPath.Studio.Plugin.Workflow.Services.AssemblyContainerBase.AddAssemblyInternal(Assembly assembly, String path)
at UiPath.Studio.Plugin.Workflow.Services.AssemblyContainerBase.<>c__DisplayClass15_0.b__0(Tuple`2 range)”

Can’t find the package.

I tried to install the studio again but nothing changes.
What can I do?

Thank you


It might be failed to install the activities package for some reason.
For now, can you try the following steps?

  1. Uninstall UiPath.MicorsoftOffice365.Activites package 2.0.1 from your project via PackageManager

  2. Close Studio

  3. Delete the following folder (including files and subfolders)

  4. Open your project then re-install UiPath.MicorsoftOffice365.Activites package 2.0.1 via PackageManager.


Thanks for your cooperation but unfortunately it doesn’t work.

It’s something computer related, because on another computer UiPath installs the package.

In the Logs I noticed this thing:
Resolving conflicts for net6.0-windows7.0…
My operating system is Windows 11. Is this normal?


Try adding this package feed…and then try redownloading the package


Hello @zactime69

Can you try with a lower version and check once.


Sorry, but it’s the same as Official.

I tried with version 1.14.1 and it installed.

Then I upgraded to version 2.0.1… It installed but, in the logs, I see the same errors as the direct installation of version 2.0.1, plus these 3:
“Failed to load assembly: C:\Users\Oscar.nuget\packages\UiPath.microsoftoffice365.activities\2.0.1\lib/net6.0-windows7.0/UiPath.MicrosoftOffice365.Activities.Design.dll”
“Failed to load assembly: C:\Users\Oscar.nuget\packages\UiPath.microsoftoffice365.activities\2.0.1\lib/net6.0-windows7.0/UiPath.MicrosoftOffice365.Activities.dll”
“Failed to load assembly: C:\Users\Oscar.nuget\packages\UiPath.microsoftoffice365.activities\2.0.1\lib/net6.0-windows7.0/UiPath.MicrosoftOffice365.dll”

Should I expect problems?

Thank you both.

Are you able to see the activities after the installation? Hope it will not make any problem.
If getting the same error, then downgrade to the stable lower version and continue.

I actually repeated the operation a second time and it didn’t work.

I installed the penultimate version and it works.


This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.