Double quotes between a variable (string)

Hey!

I’m trying to add a dataRow to my dataTable, which is built in 3 columns, like this:

Name| INC | OPR.
Nº do Incidente, “INC0001”, or

Name and OPR are just strings, and it’s fine, but INC should be written with double quotes before and after my value (item extracted from another dataTable). So I used the Add Data Row Activity like this:
{“Nº do Incidente”, Chr(34) + incidente + Chr(34) , " or"}

But when I print using the WriteLine activity, it returns this response:

‘Nº do Incidente*’ = ,""“INC000003354121"”", or

I just need one instead of three " . How should I do it?

To insert a ", you can escape it by entering it twice. For example, f I set MyStr = """", then MyStr has a value of ".

Anthony, I tried it but still doesn’t work. Look:

addDataRow --> {"‘Nº do Incidente*’ = “, “””" + incidente + “”"" , " OR"}

The WriteLine --> ‘Nº do Incidente*’ = ,""“INC000003354121"”", OR

It seems no difference to my first WriteLine :confused:

Actually I think the problem is in OutputDataTable, if I do the Anthony’s suggestion separately it works. What could I do to export my data table without this three " ?

Hi mmanetta,

Best way is to create a variable and assign using Assign Activity.

Example:

addRowStr = "Nº do Incidente, "+Chr(34)+"INC0001"+Chr(34)+", or"

And the pass your variable to datatable

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.