Disabling specific triggers in a folder using Orchestrator HTTP Request

I am working on a solution where i want to disable all the Triggers currently enabled in a specific folder on my Orchestrator server. I am using the Orchestrator HTTP Request activity.

I managed to find and extract the Key for each trigger using GET /odata/ProcessSchedules.

Now i would like to Disable the Triggers by the Key values i have found using PUT /odata/ProcessSchedules({key})

I tried using “/odata/ProcessSchedules(” + currentItem + “)” as the relative endpoint where currentitem is a string variable i extracted with he previous steps.

I am getting this error in return: “{"message":"Invalid OData query options.","errorCode":999,"traceId":"00-f5cbe3810a630d5a39fe06e7453e7f8e-7ff6b2b731179934-00","resourceIds":null}”

Hi @fredslund7889 ,

I believe you should pass the parameters through the Json Payload, Could you maybe try to pass it and check. Below is the Video Tutorial on the configuration part :

Hmm now that i look at again, it seems it expects the key to be an Integer (or am i missing something?)

When i use the GET /odata/ProcessSchedules method, i get Key string value:

image

I wonder if there is some other Key value im supposed to find and where i find it :confused:

Have a look at these endpoints

/odata/ProcessSchedules
Gets the process schedules. So we can take the Id/Key

And
/odata/ProcessSchedules/UiPath.Server.Configuration.OData.SetEnabled Enables/disables a group of schedules. We can use the IDs from above

@fredslund7889 ,

I believe the ReleaseId must be used as the key in Process Schedule Edit API.

Which IDs?

I get a list of JSON strings in return when i use the odata/ProcessSchedules, where each listitem looks something like this:

{
“Key”: “5860ad00-9dbc-4106-8241-c684b3d2a4aa”,
“Enabled”: false,
“Name”: “Name of project”,
“ReleaseId”: 51,
“ReleaseKey”: “cddbed89-c599-4bb6-be13-6d42262cb7b2”,
“ReleaseName”: “007_01”,
“PackageName”: “007_01”,
“EnvironmentName”: null,
“EnvironmentId”: “”,
“JobPriority”: null,
“SpecificPriorityValue”: null,
“RuntimeType”: “Unattended”,
“StartProcessCron”: “0 0/30 * 1/1 * ? *”,
“StartProcessCronDetails”: “{"type":5,"minutely":{},"hourly":{},"daily":{},"weekly":{"weekdays":},"monthly":{"weekdays":},"advancedCronExpression":"0 0/30 * 1/1 * ? *"}”,
“StartProcessCronSummary”: “Every 30 minutes”,
“StartProcessNextOccurrence”: null,
“StartStrategy”: 1,
“StopProcessExpression”: “7200”,
“StopStrategy”: “SoftStop”,
“KillProcessExpression”: null,
“ExternalJobKey”: null,
“ExternalJobKeyScheduler”: “117937c2-3e7f-4578-8259-43217523ecd6”,
“TimeZoneId”: “UTC”,
“TimeZoneIana”: “UTC”,
“UseCalendar”: false,
“CalendarId”: null,
“CalendarName”: null,
“StopProcessDate”: null,
“InputArguments”: null,
“QueueDefinitionId”: 13,
“QueueDefinitionName”: “007_01”,
“ItemsActivationThreshold”: 1,
“ItemsPerJobActivationTarget”: 1,
“MaxJobsForActivation”: 2,
“ResumeOnSameContext”: false,
“Description”: null,
“AlertPendingExpression”: null,
“AlertRunningExpression”: null,
“RunAsMe”: false,
“IsConnected”: false,
“Id”: 35,
“MachineRobots”: ,
“Tags”:
}

odata/ProcessSchedules/UiPath.Server.Configuration.OData.SetEnabled expects a JSON payload with this format:

{
“enabled”: true,
“scheduleIds”: [
0
]
}

So it seems it expects an integer ScheduleID? :confused:

we will reconnect later, as a preview:

grafik

Feel free to give quick shot at it within swagger

@fredslund7889

We cross - checked within Swagger and it was working when using the ID as highlighted above

1 Like

Thank you - that led me one stop further :slight_smile:

I had some issues passing in an int variable to the JSON payload.

“{enabled: false, scheduleIds:[35]}”

It worked after i formattet it like this: “{enabled: false, scheduleIds:[”+currentItem+“]}” instead of this: “{enabled: false, scheduleIds:['”+currentItem+“']}”

Just a quick bonus info if anyone else finds this thread and attempts the same. Make sure your robot account has permissions in place! I got it working fine on my development account, but it kept failing once i tried to run it in an unattended process.

So make sure you give it a role under account settings that gives it access to read/write what it needs and that it also is assigned that role in addition to the robot role in your folders.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.