Dictionary datasource not supported for GSuite!

I am following this training:

I am using Studio X, like it shows in the video, also using Studio x (this is impt later)

I am at the part where you write the first cell in the Invoice spread sheet for cell E18, when I encounter the error: Dictionary datasource not supported for GSuite!

This forum post from a few days ago seems to say the solve is to install Studio instead:

This can’t be correct. UI Path Training video shows this working with Studio X.

I updated the google package to the latest, which has a different name than what’s mentioned in the training, but I can’t find any other ones and it seems to install the right stuff, aside from this error.

The package is “Google Workspace v2.1.2”

What is the real solve here?

1 Like

This is the training like which for some reason didn’t copy in my original post:

First Automation Using Google Workspace

1 Like

I believe you are using the latest version of Gsuite package, In the training they are using v2.0.0, If you use the same version you will not face this issue, I am using v2.1.1 but when I am using v2.1.2 I am facing the same issue. So if you downgrade the version and make sure to set Runtime Rule: to “Lowest Applicable Version”

1 Like

Hi @Rob_Marton ,

Thank you for sharing this with us. If the downgrade resolves this, we should investigate this further. I’ve included @AlexCrijman that can take a closer look into this.


1 Like

Can confirm this bug. I am following similiar training, albeit for v2022.10. This error happens independent of version of “Google Workspace” package and Runtime Rule setting, I tried v2.1.2, v2.1.1, v2.0.0 and v1.17.0.
However, the project is completable if I use Expression Editor and manually enter needed cell, but it is not the intended way.

Also, on the unrelated note, the variables created during work on Read Cell step in fact, is Object type, when Type Into step requires String variable type, so when I use created variable in Type Into, there is error showing until I manually change variable to String type. Its not a big deal, but dealing with it completely absent in tutorial video. In video author just creates this variable and uses it right away with no extra steps, so it not really clear, it is tutorial error or StudioX creating wrong variable.


Hi @Raluca_Laic,

In my opinion a downgrade does not solve this problem - I tried every other version without success.
A bit frustrating tbh, because the first tutorial regarding building solutions with StudioX and Google Workspaces can not be used to build your own solutions due to this error.

Are there any updates so far? Or is there a kind of simple workaround?


Hi @Raluca_Laic and @AlexCrijman!
I’m facing the same issue with all updated to the latest versions today, and for that can’t move on with the training. Is there an idea on when a fix would be available?
Also, even after the variable was created, the same error occurs when trying to recall said variable to type the value in browser.
I can provide the error logs if you deem it useful.



I’m also getting this issue.
I’ve tried the above fixes, changing the runtime rule, changing version etc but still doesn’t work.

Any fixes yet?


Hey everybody,

Thank you very much for raising this issue. We have raised a bug, and I will come back to you once it is solved and released.

Thank you,