CV Vision

Hey guys,

we changed our orchestrator from Cloud ton on prem and our Studio/Assistant is now connected with the on prem Orchestrator. But now the Computer Vision doesnt work anymore. Firstly it doesnt recognize the screen frames right (the screen frames overlap across several screens). Moreover I recieve the error "Error details:
[Error Code: 401] Unable to activate Computer Vision: The current user is not authenticated.

To fix this, log in to Automation Cloud or copy the API key from > Administrator > Licenses > Robots and Services and paste it into Project Settings > Computer Vision > API key.

When enabled, app screenshots are sent to UiPath Cloud when viewed to ensure automation resiliency. Therefore, dummy data should be used to avoid sending confidential information."

But we aren’t in the cloud anymore as metioned in the instruction. Could you please help us? Our process that works with CV doesnt workt anymore which is very disturbing.


Please refer the following post.

1 Like

Hi @marco.roensch

If you still want to use the UiPath CV Cloud service (which is what we always recommend :slight_smile:), you need to input the CV API Key from your Automation Cloud account: Admin > Licenses > Robots & Services tab > Computer Vision. Before migrating your Orchestrator to on-premise, the authentication was done via the access token (which was getting the CV API Key automatically), as you were authenticated in cloud. Now that the access token is no longer there, you’ll need to manually input the CV API Key in your project: Project Settings > Computer Vision > API Key

If you go for an on-premise deployment, then the reply above is what you need. After deploying your on-premise server, you’ll need to replace the default endpoint value in Studio ( to your server’s endpoint url. If you go for Localserver, you need to add the CV Localserver activity package and set the Project Settings > Computer Vision > Use Localserver value to True:

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.