Create Process using API


I want to create Processes in Orchestrator in specific Folder using API, but i am not getting how to do it.
Please help me with this.


What issue are you facing?

Did you try the swagger file?

Please check this


Hi @Anil_G

Referred the thread that you shared but was confused about what should be specified in key?


run a GET for this URL

You will het all keys…of if you need a specific key then use filter conditions on it.

You have an example here


Tried with this this gives the key data only if the Process is there into Process tab. I am trying to create a process for the packages in orhestrator


for creating a process you would be running create release. In the context of API releases are the processes that you create

and for that you need the Process key and Process version which comes from the below api .In this process refers to packages

Hope this is clear


Tried but getting error as Bad Request


Then the request that you are giving is wrong…try creating the request first in swagger and use the same


i tried but still getting same error.
i am passing processkey, processversion in body


Processkey looks like a number with hyphens and all not the name…


we get process key if that process is there in orchestrator process.


In the context of api process means package…can you please check the precious screenshot i sent…

Get processes gets the packages

Get releases gets the process detaisl

So do a get on getprocesses which will give you the processkey(ideally related to package not process)


when i do get processes i get the below data

Hi @sneha_arbole1

To create processes in UiPath Orchestrator using the API, you will need to use the /odata/Processes endpoint and make a POST request to this endpoint with the appropriate payload.
The payload should include the information for the process you want to create, such as the name, version, and description.

Hi @Kaviyarasu_N

Can you please share the Screenshot if possible of payload format as it is still not working for me. i am getting 404 error