Convert .dos to .eles without Excel installed

Hello, i have to convert a file from xls to xlsx on a server but swedo not have Excel installed and se can’t install it. Is there another way to convert it?
Thanks
Liliana

Did you tried to use excel application scope and tried to create/write inside it? It should work even if the application is not installed.

Hello,
Excel scope requires you to have Excel installed and in the server we don’t have it. That is my problem, I can’t use excel scope.
Thanks,
Liliana

Hi, you can use the workbook activities instead of the excel application scope, those should work without having Excel installed.

yes but not for xls… they are not compatible with xls.

Right, that was silly of me. Try using this library, though I am not 100% sure it works without excel installed: UiPathTeam.FileConverter.Activities
Hope it helps.

Hello,
I installed but it requires excel… Gives me this error:
Convert XLS To XLSX: Retrieving the COM class factory for component with CLSID {00024500-0000-0000-C000-000000000046} failed due to the following error: 80040154 Class not registered (Exception from HRESULT: 0x80040154 (REGDB_E_CLASSNOTREG)).

Yep, Sorry i meant to say it wouldn’t work if the application is not installed if you use excel application scope. My bad - i said it as “it should”, If you use excel application scope - it would require Excel to be installed, by using the workbook activities it doesn’t require the applications to be installed in your PC. but reading the further comments your problem now is it is not working with xls when you use workbook activities? Ideally It should work with both xls and xlsx even if the excel is not installed on ur system. what error are you getting for it?