Column does not belong to DataTable - Please help

“Type Into ‘INPUT’: Column ‘first number’ does not belong to table DataTable.”
every time I run my robot the robot stops and sends me this error and I don’t understand what does it mean, please tell me what should I do in this case

1 Like

@Omar1 Please change the Title to a suitable one , so you can get proper help on it

Regarding your question it seems that the first number which you used in Type into does not belong to data table
please check if your datatable contains that column name

If possible can you add the screenshot

regards
Shanmukh

Hey, @Omar1
try doing this row(0).ToString instead of giving column name
you can cross check if you are passing the right Column name or not
cheers

Hi @Omar1,

Can you please provide some screenshots to explain your topic and make it more clear?

Thanks & Regards,
Apurba

@Omar1 You screenshot is blur, please add a new one with explanation of what is happening

Can you Print the CustomerData datatable and show us
To print you can use Output datatable give input as Customerdata and output for that as Text and then use message box ,in box give text

just click on it and it will open

Columns “first number” and “last number” don’t exist. Did you mean “first name” and “last name”? :wink:

2 Likes

OMG!!! i didn’t recognize it

thank you very much

1 Like

Good morning everyone,
I hope everything is fine with you all :slight_smile:
I have been going through this same error mentioned at the top and I have tried all the solutions here, but still I’m getting the same problem, here is the error I got everytime:

“message”: "System.Reflection.TargetInvocationException: Exception has been thrown by the target of an invocation. —> System.ArgumentException: Column ‘LicenseModified’ does not belong to table DataTable.\r\n at System.Data.DataRow.GetDataColumn(String columnName)\r\n at System.Data.DataRow.set_Item(String columnName, Object value)\r\n — End of inner exception stack trace —\r\n

image
I tried row(“LicenseModified”) and row.item(“LicenseModified”) but no outcome,
Can someone guide me, please?

Thank you very much in advance

Could you just check column name once more whether it contains any spaces between @Ghaith_Slimani

@nikhil.girish , thank you very much for your reply, I have checked that, but still getting the same error, by the way, I’m adding that column in a previous step and here how it is , any trick?
image

I would recommend you to print the column names of a datatable in immediate panel once

After this add datacolumn activity just drag a breakpoint @Ghaith_Slimani
YourDt.columns.columnName

Thanks