Client security Hash_ ERROR

Hello everyone,

I finished the Exercise of the Client security Hash training, I had encountered this problem while running, I don’t understand the error.

HI @sarra.meziane ,

Can you show me what you have mentioned in right side of assign ?

Seems the item you want to fetch is overreached index .

1 Like

Hi @sarra.meziane
Seems like so

Can u translated in English as it seems In other language so that we can get the idea

1 Like

index was outside the bounds of the array

Yes, I know .because my table is empty I don’t know why
I’m stuck here it’s been several months I haven’t been able to solve this problem. (2.4 MB)

the list of WI5 is still 0 I don’t know why,
Can you help me please ?

Let me check the code, give me sometime.


Ok thank you I lot. I’m waiting for your feedback

Hi @sarra.meziane ,

I tried running your project, it is not even reaching to that point for which the query raised.

You need to correct few things.

1 - When ACME login once you should not logout again, use same login further.
2 - When bot is updating unique code , the ok button selector is not working so please make it dynamic.

3 - when i tried to run one case it is not even worked end to end.

I will suggest to make it error free first so that bot can process all items end to end on any Environment.

But if you just looking to correct index issue then change condition as

Hope this will help you.

I corrected what you told me but my problem remains the same