CI/CD Pipeline configuration with Uipath and Gitlab

I have the latest UiPath CLI packages and I am trying to integrate that with GitLab CI/CD pipeline to run automated tests via Orchestrator. I am having some issues configuring the “gitLab-ci.yml file”. Has anyone done this before? I know there were some tips and ideas on YouTube, but that was done on Jenkins and other ways and the challenge has been configuring that file. I would love to get some ideas. Thank you so much!


Welcome to the community

Please check this

Hope this helps



Did you checked this?

My issue was with the packaging part using the UiPath CLI.
The package was created but was not good to use. I was created in some strange way, different from the usual. The structure was different from the ones published by Studio, and the Orchestrator doen’t accept it as normal package.

Hi @Carlos_Patricio2, Thank you for the quick response. I have not looked at it and I will take a look at it today. Thank you so much. I managed to unpack the UiPathCLI packages and connect them to the orchestrator. I ran “my tests” locally via the CLI and it did run very successfully. The challenge – at least for now, is to implement it via GitLab and running it not locally. :laughing:

Hi @Anil_G ,

Thank you for the response! I will look at it now. Thank you for attaching it! =) I think I did see the DevOps scripts, but UiPath, in November released their UipathCLI products and you can have that package and just use the “UiCLI.exe” to execute tasks instead of that given process, which is what I am trying to implement. I might go one step back and try the DevOps scripts instead.

1 Like

Hi, also, this is the package I am using now, which was released by UiPath, if it is helpful. =)

UiPath-Official - Azure Artifacts (


I’m not sure if I was using the last version.

I will give another try and let you know.

Thanks again :slight_smile:

1 Like

Hey @Carlos_Patricio2 ,

Did you manage to resolve things on your end? We found a resolution on my side and managed to integrate UiPath with GitLab. Let me know if you still need help! =)

Hi @kuna.sheelan,

I’m very glad that you manage to make it work :smiley:

These days I have been a bit busy, I will take a try with this new CLI version and let you know.

Did you used the Github script as-is or did you made major modifications?


1 Like

Hey @Carlos_Patricio2 ,

We had to modify the script. We basically wrote a script to download the latest “.Net” version, get the “UiPathCLI” from Artifacts and run the “UiPathCLI.dll” and it worked. The pipeline is executed. Problem now is how to manage UiPath packages and workflows on GitLab, which should be fairly easier than this integration issue. This was a tough one.

Anyways, thank you for your responses and ideas. It helped as well. All the best! Do reach out if you ever have to do that portion again and run into blockers! Keep Automating! :grinning:

Hi @kuna.sheelan ,

I already did some very basic pipeline on Gitlab, the problem was the Packaging part. My robot folders are in the same server as the Gitlab. The script are also saved on that server.

The .gitlab-ci.yml inside each branch (let’s say UAT and PROD) will call each script with different inputs (Orchs url, and auth details will change.)
Everytime you do a commit to UAT or PROD branch it will run the pipeline automatically, creatin a package, testing and deploy to Orchestrator, depending on the stages you have enable.

Now I’m having this issue with the .Net and I’facng issues to install it.
uipcli.exe : You must install .NET to run this application.

Are you running uipcli.exe or UiPathCLI.dll?

Thanks :slight_smile:

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.