Can't use Run Python Script due do pipe limitations

Hi there, i came into conclusion that i can’t use a variable with a length higher than 25 characters when running a Python Script. I receive an error, about the pipe saying it is broken.

The thing is, i’m trying to get a variable from Google Document AI and it symply crashes because of the size of the variable. Pay in mind that i’m returning any value, i’m just trying to run a .py file

Does anyone know a way to increase, UiPath, pipe size?

1 Like

Hey @ricardo-banon.jesus

This is just my guess, Is there a chance you can split your string into smaller chunks please ?


Hi @ricardo-banon.jesus,

Welcome to the community!!.

This might be a product Qs. @loginerror can help you here.


Hi @ricardo-banon.jesus ,

There are similar posts related to the Pipe is Broken Issue. But I am quite not sure if the reason is due to the length of the value present in the variable.

Take a Look at one of the Posts below :

The issue can be somewhat related to importing the modules or Providing the appropriate working Folder in the Properties Panel as well.

Let us know what is the Python Code intend to do, and if Possible what is the Code Structure or you could drop the Code Itself in the Preformatted Text format </> for further conclusions.

I have to disagree because when i insert a String with less than 25 characters, the program runs just fine and can run the python just fine as well, that’s why i came into the conclusion it’s because of the length of the variable.
If i had issues with the working folder or the code, it wouldn’t run with a variable with less than 25 characters am i correct ?

The thing is, this string that we are talking about is something that i get from Google API. And since the python code connects with google an receives all that information, i don’t know how to divide it in chunks before i receive it :frowning:

1 Like

I mean not before you receive it but in the python code before it comes to UiPath…


yes i can, i tried to write instantly to a file the chunks of text, but it still broke the pipe :cry:

If you downgrade UiPath.Python.Activities to v1.3.0, you should have more usefull feedback. You might also be interested in using python logging.

1 Like

Thanks, i will try doing that and i will give feedback.

1 Like

Unfortunately the downgrade didn’t work.

What i did to bypass this problem, was running the script through DOS, i installed python on the windows terminal and run “python name of the” and it worked what i intended.

Thanks a lot to everyone who tried to help

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.