Can't insert data into database table

image
I am using data scraping and have assigned each row of the datatable which i have got from the sacraping of a website to a variable. The picture shown above is showing all the variable names that i am using after “value” in my insert query. My insert query is like-
“Insert into tablename (column1, column2,…column13) values (the variables shown in the pic above);”
I am writing the query in the non-execute query activity of uipath. The showing is invalid “column” name whereas all those are the variables. I have also used the connect activity before the non-execute activity.

@diptojyotidutta Are you using the same column name in the table in the database. The column name of the datatable and the database should match.

@vishal.kp no i am not using the same column name as that of the datatable.
Actually the problem is that the Website from where i am scraping the data has special characters in it. Plus i wanted to split some rows as some rows had multiple data.
For example- row(0) has Both Billno. and Date in it and i don’ want it to stay in that way.
As a result of that in my database table i created to separate column, one is Billno, and the second is Date. There are two such rows which i split into two. And i am taking the data from the datatable(data scraping from website) to my database.

first of all for your data to get transferred to database.Your column names should match.Match it and try. edit in sql the same column name as of data scraped.

I have tried it before but it didn’t worked at that time as well. I even tried to do away with the spaces in my column name but that too failed.

can u share the workflow