Cant add sharepoint list item

I am using a table to insert items into a list, the activity “get list” works fine but when I use the activity for adding list itmes (array using a table) I get a rejection that the data cannot be written.
The old sharepoint activities in windows classic worked just fine so I don’t understand why this is failing.

this next sreenshot shows that the field does exist, it is a string, and it is named correctly

Note in my “build data table” I also included a duplicate row of the headers just in case those were not getting transferred, because when using the data table mechanism the instructions say the first row needs to be the column titles, and second row so on needs to be the data being inserted.


For now, can you try to modify “AgencyName” to “Agency Name” in your datatable?


I tried that, but from experience it needs to match exactly the SharePoint name which is pulled from the end of the URL

Hi @Nathan_Betters1

Does you list contain data?
there should be at least one row before using this add list item with all columns filled

Can try this as well but I generally see it is the backend name itself

To check the backend name you can inspect the element as well …some times space is replaced with _ also …its better to inspect and check


The table has data