Cannot use UiPath.Excel.Activities since Office 365 update


Since I updated my Office version to 365, my UiPath is not able to launch Excel anymore with UiPath.Excel.Activities.

I have the following error :
RemoteException wrapping System.Exception: Erreur lors de l’ouverture du classeur. Assurez-vous qu’Excel est installé. —> RemoteException wrapping System.InvalidCastException: Impossible d’effectuer un cast d’un objet COM de type ‘Microsoft.Office.Interop.Excel.ApplicationClass’ en type d’interface ‘Microsoft.Office.Interop.Excel._Application’. Cette opération a échoué, car l’appel QueryInterface sur le composant COM pour l’interface avec l’IID ‘{000208D5-0000-0000-C000-000000000046}’ a échoué en raison de l’erreur suivante : Interface non enregistrée (Exception de HRESULT : 0x80040155).
à System.StubHelpers.StubHelpers.GetCOMIPFromRCW(Object objSrc, IntPtr pCPCMD, IntPtr& ppTarget, Boolean& pfNeedsRelease)
à Microsoft.Office.Interop.Excel.ApplicationClass.set_SheetsInNewWorkbook(Int32 RHS)
à UiPath.Excel.WorkbookApplication.StartNewApplication()
— End of inner exception stack trace —
à UiPath.Excel.WorkbookApplication.StartNewApplication()
à UiPath.Excel.WorkbookApplication.InitializeExcelApp()
à UiPath.Excel.Activities.ExcelApplicationScope.<>c.<.ctor>b__48_0(WorkbookArguments args)
à UiPath.Excel.Activities.ExcelApplicationScope.Execute(NativeActivityContext context)
à System.Activities.NativeActivity.InternalExecute(ActivityInstance instance, ActivityExecutor executor, BookmarkManager bookmarkManager)
à System.Activities.ActivityInstance.Execute(ActivityExecutor executor, BookmarkManager bookmarkManager)
à System.Activities.Runtime.ActivityExecutor.ExecuteActivityWorkItem.ExecuteBody(ActivityExecutor executor, BookmarkManager bookmarkManager, Location resultLocation)

I tried all solutions already found in the forum but none of them worked :

  • uninstall/reinstall office
  • repair office (easy and offline)
  • unistall/reinstall uipath
  • uninstall/reinstall UiPath.Excel.Activities
  • make sure registry {00020813-0000-0000-C000-000000000046} is on Win64 (like my OS and Office version)
  • remove registry {00020813-0000-0000-C000-000000000046}
  • remove OFFICE.DLL in C:\Windows\assembly\GAC_MSIL\office\

If anyone is able to help me, it would be very welcome. :slight_smile:

Thanks a lot.


if it is 64 bits version of office, that would be why it doesnt work…

Yes I have 64 bits version of Office 365.
Why do you think it should not work ?

because the studio is 32 bits and things cant mix and match…

1 Like

Hi @emahieu

Welcome to UiPath Studio !

Hi @bcorrea ,

Yes. I am using the studio in 64 bit OS. UiPath studio works in 64bit OS.


Hi, i did not say this… ofc everyone uses OS of 64 bits for several years now :slight_smile:

1 Like

Thanks balupad14,

I already checked my registry and I only have Win64 one. :frowning:

1 Like