Cannot send input to UI element because it is outside

"Cannot send input to UI element because it is outside of screen bounds. "

when we are put data in ERP system we will get this error not every time some time we need to understand what is that error so i can find out the solution

Hi @Ram_Gurav1,
It is possible to be something with the machine’s resolution. For debugging purposes, you could try Element Exists activity to see if the element was found and if “yes” then the Highlight activity to see which is the element that was found.

Hi Ram, Did you found any solution of this? I’m also getting the same issue

I’m also having the same issue, from something I know it’s inside the resolution boundaries…

1 Like

Is the element visible when this error occurs, or would you require to scroll down or right before clicking on it, should you do it manually?
The main window can be in bounds of the screen resolution, but elements might be a few pages down… gotta love those scrollbars…

If the answer to this is yes, you might want to play around with the input method: simulate click (or simulate type, whichever is relevant) is not bound by these restrictions, the classic physical click is as far as I know.


This solution worked for me. the element was down and it was throwing same error mentioned above, when checked SimulateClick option, it worked fine for me.

Thank you

“Mouse Scroll” solved same problem for me.

SimulateClick option did work for me.


SimulateClick option worked for me!!! THANKS!!!

May I know which package contains SimulateClick activity. I am not getting it while searching in the Activity tab. Please connect with me at

Hi all,

In my case I had to set the property of “Use Application/Browser” → “Open” to ‘Never’.
please see the screenshot attached. I believe this option is available in newer version of Studio :wink:


It is the “Click” activity, and the “Simulate Click” is a property value for the Click activity.