Cannot run/install the program after update 2023.4

I was working with the community edition and the forced update for the 2023.4 started so everything closed.
In the middle of the update the computer turned of and when I turned it on again I noticed that the updater wasn’t doing anything and after four hours still didn’t finish, so I went and tried to install the program again.
It didn’t let me do it so I uninstalled the program and downloaded the installer from the cloud.
However when I tried to install it again it shows me this message:

In spanish it says that the program is already “announced” (instead of installed, although I don’t know what that means or if it is a translation error) therefore it won’t let me install and asks me to run in silent mode.
So I ran it with silent mode with this command:
msiexec \i UiPathStudioCommunity.msi \q
And it installed** but now it asks me for license key although I’ve been using always the community edition. I can’t change the licensing mode neither because the options appear disabled:

What can I do?

** Although it shows in control panel → add or remove programs list, but if I try to modify the installation it shows error saying that that option is valid only for installed productos only.


Please check this on how to remove UiPath completely and then install again using community msi please


Hello, thank you but I tried it and it still shows the same message when trying to install.


First try opening UiPath assistant and sign in from there…then open studio again


I tried but I still get error:

I tried with and without the “orchestrator_” at the end.
I tried these 2 ways too but still can’t do it:

In conection type I only have options to connect by machine key or client id, none work.


Ideally youshpuld be getting a option to login using service url or interactive sign in option

Can you recheck the msi you installed is that the latest community msi or is that any enterprise msi you already have?

Also can ypu check if uirobot is installed you can check from task manager services if userhost service is present or not


I downloaded it from the cloud and I guess that assigned me the community version. Maybe it’s related to the way I installed it with the command msiexec? Normally you should be getting an UI option to select what you want to install when installed in the normal way. Is there a command to install community?

Could you please describe in a step-by-step way all the steps you did till you reached the error? Please let us know all the details so we could take a look and investigate the issue.

Sorry for the detail. Didn’t see the answer.
As for the step by step, I’ll try my best =(

  1. As mentioned, my notebook shut down during the update. After turning it on. I was expecting the update to continue and finish but it never happened.
  2. Stopped all UiPath processes. uninstalled from control panel.
  3. Tried to install again from the msi that i got from the orchestrator url.
  4. Showed error of “program already announced” as shown in screenshot.
  5. Installed the program with the msi silent command. Installed.
  6. When opening the program, it didn’t allow me to connect to community (only allows to install with licencse) as shown in screenshot.
  7. Uninstalled the program. Erased all cache as suggested by answer. Reboot notebook.
  8. Tried to install again. Same error as 4.
  9. Installed again with msi silent command. Opened again. Same problem as 6.

I stoped trying so far so if you have something else I can try please let me know. Thank you in advance.

Thank you for this information. I will pass your message on to our developers. It’s an interesting case and definitely, we should take a look at this and help you solve this problem. Please stay tuned.

Hi @Palayn,
I got the response from our devs:

We think the user reinstalled Unattended (as opposed to Attended as it was for Community) and this is why Studio does not let him ‘Sign In’
He should go to Add/Remove Program → UiPath Studio → Change → and untick ‘Register as Windows Service’