Cannot access a closed pipe - v 2022.4


Ever since I upgraded to UiPath Studio version 2022.4, I’m encountering a problem opening files from the Project Panel. Here is a screenshot of the error message:


Does anyone know how to fix this?

Hello @Rullah ,

Can you take a backup of the project and delete the project.json and try to open it again.
Also you can update all the packages.

Hi Rahul,

I created a backup of the project and deleted the project.json file. I have also checked that all packages are up to date.

Any other ideas?

Hi @Rullah ,

Is it happening for all the xaml files or for some files?

This is happening to all the xaml files. It occurs at random. Initially, I can open any xaml file without issues. Then, at random, I want to open a xaml file, and this error occurs.

Looking through the Project log files and I think this message is pertinent to the problem:

09:18:11.6880 => [ERROR] [UiPath.Studio.Project.exe] [2] OnTaskUnobservedException: System.AggregateException: A Task’s exception(s) were not observed either by Waiting on the Task or accessing its Exception property. As a result, the unobserved exception was rethrown by the finalizer thread. —> System.ObjectDisposedException: Cannot access a closed pipe.
at System.IO.__Error.PipeNotOpen()
at System.IO.Pipes.PipeStream.CheckWriteOperations()
at System.IO.Pipes.PipeStream.BeginWrite(Byte buffer, Int32 offset, Int32 count, AsyncCallback callback, Object state)
at System.IO.Stream.<>c.b__53_0(Stream stream, ReadWriteParameters args, AsyncCallback callback, Object state)
at System.Threading.Tasks.TaskFactory1.FromAsyncTrim[TInstance,TArgs](TInstance thisRef, TArgs args, Func5 beginMethod, Func`3 endMethod)
at System.IO.Stream.BeginEndWriteAsync(Byte buffer, Int32 offset, Int32 count)
at System.IO.Stream.WriteAsync(Byte buffer, Int32 offset, Int32 count, CancellationToken cancellationToken)
at UiPath.CoreIpc.IOHelpers.d__8.MoveNext()


Can you refer the below trouble shooting guide. post is little old but I think the methods mentioned will help you.

Hi Rahul,

Thanks for your help. I tried this from the Troubleshooting Guide you referenced:

  1. “When trying to run the project, I receive the following error: System.AggregateException: One or more errors occurred.
    The problem is that UiPath.Service.Host process (the robot) was not restarted at all after the upgrade.
    This can be done by killing the process in task scheduler, restarting the robot tray or logging out/logging in to your windows account.

Let’s see if it helps!


Then plz try this step also.

This can be done by killing the process in task scheduler, restarting the [robot] tray or logging out/logging in to your windows account.

I closed all the processes related to UiPath in Windows Task Manager and also signed out of my UiPath Assistant. Unfortunately, the problem is still occurring.

Can you go to Task Scheduler… Not only in Task manager, you need to kill the process in Task scheduler also.

Killed all UiPath related tasks in Task Scheduler and still getting error message. Very stubborn error.

@loginerror Any thoughts? I can see you’ve dealt with something similar in the past.

I’m having the same issue.

  1. Open Studio
  2. Open one xaml
  3. Make changes to the xaml
  4. Try to open a different xaml
  5. Error…

So as a work around

  1. Close Studio
  2. Open the two needed xamls
  3. Work on them
  4. Try to open a third xaml… Error
  5. Goto step 1, but open the three needed xamls
  6. Repeat as needed

Literally every time I try to open another xaml, I have to close Studio, reopen Studio, open all of the xamls I need, and do work until I have to open another xaml and repeat the close, open, open all.

On a side note, which I believe is related, if I try to copy any activity in Studio, Studio hangs for 20s. I can’t click on anything within Studio, it’s hung. Then it comes back, I can paste, but the next copy hangs for 20s. I’m betting, whatever is causing the hanging, is causing the xamls to not open.

Is this a corporate policy issue (group policy) and/or antivirus issue? I’m asking because my personal machine is NOT having this problem, only my work and client machines are having this issue.

1 Like

Also facing this issue since I upgraded to version 2022.4.1

Hi @Rullah

Have you tried uninstalling & reinstalling uipath studio.

Yes, that is actually the first thing I tried. Since the machine I am using is a corporate machine, I suspected there may have been an issue with permissions. I had an administrator install UiPath from scratch. I still am having the issue.

Uipath have release the 22.4.3 which does not seems to have this issue anymore for me. Can you try that approach ?

I will try this and let you know.

I tried it, and the problem persists.

Did u solve this issue? i’m facing the same problem.

I did not.