Apply non-working days restictions

hello,

i need a help. I want to set the process on the orchestrator.
this process is expected to be at 4.30pm Monday through Friday every working day, but apply non-working days restictions dosen’t work.

recently the process wanted to go on Saturday 18.07 :frowning:

image

Change your ? to MON-FRI. Also, make sure the timezone in your screenshot matches that of the machine on which the bot is running.

2 Likes

i am sorry
I forgot to write that it should be between 10 and 18 day of month.

As written, your cron expression will do that. You just need to make the change I’ve specified to ensure that it doesn’t run on Sundays and Saturdays.

Thanks,
i know it, but i dont know how :frowning:
0 30 16 10-18, MON-FRI * ?* - it didnt work

You have 0 30 16 10-18 * ? * and need to change it to 0 30 16 10-16 * MON-FRI *, replacing your ?.

yes :wink:

0 30 16 10-16 * MON-FRI * - dosen’t work :frowning: i need a help :frowning:

What does it do/fail to do?

What if you remove the last asterisk and make it 0 30 16 10-18 * MON-FRI. The year isn’t mandatory, so it might be throwing an error since leaving it blank indicates that the year is unimportant.

Remove the period at the end.

Try replacing MON-FRI with 1-5. That parameter should accept mon-fri, but I’m suspicious, since it’s the only parameter that doesn’t have to be numeric.

still :frowning:

I have another idea. See if this works for generating the expression you want:

I must be missing something in the expression, so maybe this GUI app will help.