You guys really need to fix the naming on this, it outputs a list, not a collection.
They are clear and distinctly different object types.
And before anyone posts telling me how to use it ‘correctly’ by using a List, I know how to make it work, I am saying it should ouput a collection.
One section should deal with lists. The other should deal with Collections, using iList and iCollection as inputs as appropriate and outputting Lists and Collections respectively.
Conflating the term Collection with List is just setting you up to confuse the hell out of people.
Especially since the inputs for activities like Merge Collection accept two iCollection as the input but then output a List