Advanced training assignment 1 invoked workflow argument problem

Hello,
While performing advanced training 1, stuck at system1_login invoked workflow
As per Calculate Client Security Hash pdf


  1. unable to assign default value to password variable
  2. if we put SecureString type to the out_password argument then it show error

    If we put String type of the password argument then it won’t show error but is it valid to do so.
2 Likes

password variable should be of type SecureString. You can change it in the variables tab below.
It is not in the list by default, browse types(last option) and then search secureString and use it.

@sagaryeole

I think that the direction of out_password variable should be out.

Regards,
Karnik

1 Like

I have a created variable for password with SecureString type but when I enter some password value as default it shows error.

hi @sagaryeole

Did you check my suggestion?

Regards
Karnik

Yes.

Did it work?

Sorry, but you cannot put the value in the activity directly for secureString. Please enter it into the properties panel(on the right side) field secureText and then only it will work.
This is a security thing in UiPath. this will solve your issue.

1 Like

Hello,
I am not getting what actually you mean to say which activities properties pane where we have to store the password value. I was trying to store the password value in variable “password” in System1_Login workflow but whenever we pass the default value in password variable it show error.

image

In the above screenshot, the variables are just assigned to store the username and password from your GetAppCredential workflow. Do not hardcode any default value.

1 Like

Please check the error in System1_login

image

Add the Credential package in the manage packages option. and try again. It will work.

1 Like

Yes It worked and successfully login to ACME.
Worked with get credential activity.
Thanks again @nadim.warsi

Great!!! Please mark the answer as solution so that this thread will be marked solved for the community people to refer to later :slight_smile: Thank you