Add Data Row: This Row Already Belongs To Another Table

hey guys, i’ve seen others using invoke method to solve this problem when the program is ran. however, when i tried to use it, it returned me this error.

so here is my context, i have a datatable dt in another process, where i extract this one datarow dr from dt, then i pass dr to another process through invoke argument. initially i tried to use add data row to add dr to this newly built datatable dt2, but i got this problem (title), and i research upon it, i found that i have to use invoke method, but i got this when i tried to implement it.

so here are the screenshots of the activity details
in_transactionitems is the datarow dr
exceltable is the dt2 that i’m trying to pass dr into


Please check below thread.

DataTable does not have public instance method named "ImportRow"

thanks for replying, turns out instead of missing parameters i assigned the wrong variable type.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.