Unable to cast object of type 'newtonsoft.json.linq.jobject' to type 'system.string

Hello Niket,

Thanks for taking out time to check this. I ran this, but still, it is showing invalid selector. What I am trying to do is, I recorded the sequence of scheduling drop by pointing at pencil at one of these coloum. It was working fine. But I want it to be dynamic and ask me column value for which I want to schedule drop. Any other way to automate my drop process?

Hi! I made some changes!

See that there are 9 columns and the column in which pencil exists are starting from Column 7.
So the range of input dialog should be from 7 to 9. I have attached the workflow:
TransportDropAutomation.xaml (21.0 KB)

I hope this works for you! Tell me if it does!

1 Like

Hello Niket,

Thanks a lot, it worked perfectly fine. Though pencil is not showing for others, as I tried to put drop in them but later cancelled as I can’t leave them as it is. Pencil will start from 3 column itself. So as per I can identify after watching workflow, it was the delay which was required apart from what was suggested by Akash above. Is there anything which I was missing.

I am quite new to UiPath, just completed RPA foundation developer training. Trying to use my knowledge by automating daily life activities.

1 Like

Yeah if the pencil starts from Column 3 then simply increase the range, also for better workflow, you can validate the input(the ColumnNumber) by using an if statement if by chance you press any number out of range your workflow won’t stop!
I also changed the selector a little bit! I indicated it again and it worked!
I hope this will help you.
Also mark it as a solution if this was what you were looking for :slight_smile:
Happy Automation! :slight_smile:

1 Like

Not sure, How to mark this as solution

I marked it solved for you :smiley:
I think you click the 3 dots on his post, then there is a button for Solve.



Thank You Clayton

I am only getting like, share, bookmark, privately flag after clicking on those three dots.