Cannot deserialize the current JSON object (e.g. {"name":"value"}) into type 'Newtonsoft.Json.Linq.JToken' because the type requires a JSON array (e.g. [1,2,3]) to deserialize correctly, how to resolve this?

Its working in my local , if i publish to orchestrator and run its not working

in general it looks like a JSON array is tried to get serialized but the passed JSON is not a JArray.

Can you share with us:

  • details of your implementation
  • the JSON which is to get serialized
  • a description of the what is to achieve
1 Like

Actually , i had one sequence which is working fine for 4 to 5 projects, the same sequence i copied and executed in my local, its working fine …

when i publish its not working, there wer no errors before publish

Hello @MitheshBolla Ref below thread

1 Like

i dint understand what to do, should i create complete project again, or should i uninstall any package?

Hey @MitheshBolla

Nope wait let’s troubleshoot first.

Did you recently upgraded and degraded robot ?

Or is there is any version conflict of robots in dev and prod ?


1 Like

I upgraded packages in my studio,

Hi @MitheshBolla ,

As a First Debugging, Could you check by keeping the same package versions as that you have maintained in the local ?

Let us know if that’s not possible or if the Error still exists.

Also let us know the Studio Versions and the Robot Version in VM.


To something more compared to studio version ?

1 Like

I had reinstalled , in vm it has worked fine.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.