Yearly Report Performer - Can't Get Text of Conformation ID

I am receiving an error in my UploadYearlyReport.xaml file. I have modified the selector sooooo many times and still no luck. When I modify it, I replace the ID to a wildcard and it will be valid, however when the bot gets to that point of the project(which also takes like 15 minutes), I get this error.

Get Text ‘Static’: Cannot find the UI element corresponding to this selector:

<wnd app='iexplore.exe' title='Message from webpage' /><wnd aaname='Message from webpage' cls='DirectUIHWND' /><ctrl name='Message from webpage' role='pane' /><ctrl name='Report was uploaded - confirmation id is *' role='text' />

Here is my selector:

I have been facing this issue now for hours and I don’t know what else to do. Any suggestions would be greatly appreciated!

I just came across this issue now. It will run through for the 1st transaction, and then for the 2nd the selector is invalid…

1 Like

Hello @kmulq Here are some things you can try:

  • Changing the WaitForReady properties of the Get Text to “Complete”
  • Adding delays before the Get Text activity.
  • Adding an Element exist activity before the Get Text activity.
  • Try using “if” statements containing the particular activity.

If none of these work we’ll try other workarounds. You can also try posting your uploadyearlyreport workflow if you want, so that I can have a better look at it.

Hi,

Try you can use attach browser activity to attach the popup page and in the do section you can put get text activity to get the data.

Thanks for the reply. Unfortunately none of those worked. If you wouldn’t mind looking at my work I’ll upload it here.

System1_UploadYearlyReport.xaml (12.2 KB)

Thanks for the reply. Unfortunately that didn’t work.

Hello @kmulq, can you try this?
System1_UploadYearlyReport.xaml (14.3 KB)

I think I figured it out, but I don’t know why it works. I didn’t change the selector and for whatever reason it started working. However, it would make it through about 10 transactions before it would fail. That started happening because the notification window that had the confirmation ID changed. It contained a small checkbox at the bottom that said something like “Do not let this window show any more messages”. So I just checked if that element existed. If it did, then I used Get Text with that selector. If it didn’t, that meant that the normal window showed up so I used Get Text with that selector. After that I made it through all of the transactions. I submitted the assignment and passed. Thank you for your help though!

1 Like