Yearly generate Report /Processing transaction number error

Could not solve this error , Help me out .Thanks!

1 Like

Have you changed the type of in_TransactionNumber anywhere?
It should at all places be Int32 only. Can you check once the variables and arguments inProcess xaml.

Hi @nadim.warsi
Thanks for help,

I have rechecked every variables every in_TransactionNumber is Int32 only.
still same error is occuring.

Can you show “Process” file arguments

Yeah same error is occuring,ImProcess.xaml (20.2 KB)
attaching the ZIP file ,do watch and suggest me.

1 Like

And what arguments using in Main.xaml in sequence “Process”?

I cant get u ,I’m attaching main file also.Main.xaml (52.1 KB)

Still its is scraping data continuously ,and showing below error.

When you are running and it threw an error, it automatically goes to the activity that has failed
Can you tell which one failed?

You are missing some variable mapping.

Let us check that first

This is Error in process ,click item and below ElementAppear also has error.

I guess you need to do some changes there to make the aaname dynamic.
In the instruction it is mentioned how to do that.

That way only will it be able to keep going to the next page.
Right now with this code, it will keep looking for page 3 as being active and not click the next pages

Read the steps once again and see if you are able to understand what is required here to go to the next page using the bot

Yeah , I will check out and Update you again Thanks !

Hi @nadim.warsi In generate yearly report there is error in GET Text ,I have attached the pictures let me know where is the error.
For 1st transaction the text im getting in second transaction it is popping an error.

This is the Error

This is how i set the selector

Ok One question.
Did the pop-up come once the report was uploaded?

@nadim.warsi everytime bot upload the yearly report we get the popup.

1 Like

Yeah! After uploading the confirmation message has displayed , next the text is not copying further .Showing error like could not find Get text Element as shown in above pic

Then can you please re-indicate the selector for that activity?
Did you edit the selector post indicating?
Mine looks like this:

<wnd app='iexplore.exe' cls='#32770' title='Message from webpage' />
<wnd ctrlid='65535' title='Report was uploaded - confirmation id is *' />

yes we changed the selector but still its not working