Write Cell: The given key was not present in the dictionary

If i use write cell with new empty excel, it works and write cell value. When i tried to use in our existing excel, it is throwing an error.


Any help?

HI @pushkar.singh

Instead of writing the data using Write cell have tried to update them in datatable and then write the updated datatable in the sheet you want


What is the error it is throwing?


Please try the following.

  1. Upgrade or change the excel activities package
    2 Alternately try with excel activities to check even then you get thw error…
  2. Specifying thw error you receive can give more info.
  3. Try saving the same excel again as a different excel using save as…sometimes excel meta data might be corrupted and it might be non readable for the bot


Write Cell: The given key was not present in the dictionary

  1. Excel activities are working fine with scope. Actually excel activities are taking time in saving/reading data from excel so I want to replace it with write cell which is fast.
  2. I tried with new excel and it works. If i use my existing framework excel (which has many rows [Screenshot above]), it throws an error and enters random data in the sheets.


The error says some config value you are using is not present or some key is missing

On the new excel if it is working…then please save the same excel using save as and use that …may be the file is corrupted.This would be a one time activity

Hope this helps