Write Cell activity resolves in "Read Range: Syntax error."


i just discovered the following bug:
When using the “Write Cell” activity with an excel sheet that contains a formula in the same row that is written to, the excel file became unreadable with the “Read Range” activity.

When using the “Write Cell” activity in an excel scope, the file remains readable with the “Read Range” activity.

Testet with UiPath Studio 2020.10.10 and UiPath.Excel.Activities 2.10.4.


Full sequence:

Main.xaml (7.3 KB)
Template.xlsx (8.6 KB)
ExcelBugWriteCell.zip (8.7 KB)


Already you placed the Read Range in the top, Why are doing the same again?


Hi @Dennis0

Please try below things,

Put a delay activity between write cell and read range and set a delay of about 1 or 2 seconds.

And also give range as “” instead of Empty.


It is only an example that shows the error:

  • Read Range before Write Cell => OK
  • Read Range after Write Cell => Error

@Dennis0 have you tried this things?


Still the same error.
After the Write Cell activity the file is broken and cannot be read by the Read Range activity.

Hi @Dennis0 ,

Thank you for the sample project, I was able to repro this. We’ll look into this but in the meantime, the correct workaround is using the Excel Application Scope.


The Workbook Read Range and Write Range activities are better than using Excel Scope. Try those.

Hi @postwick ,

In this case, Read Range is what is causing the error. The correct workaround here is using a scoped activity while we’re fixing the issue.


Put the range as “A1” instead of blank. I had the same issue, this solved it.

If there is an issue with the version of UiPath.Excel.Activities they’re using, they should use a different version not use the less efficient less stable scope activities.