Workflow Unable to be opened; "Document is Invalid"

I was developing a Bot on a Virtual Machine and after restarting my VM the workflow is no longer able to be opened. It was working fine previously.

I am getting the following message: “Open Document Error: Document is invalid”. When looking at the log it says it cannot find file Microsoft.IdentityModel

I have tried the following resolutions with no success:

  1. Restart my Virtual Machine
  2. Delete the .JSON file
  3. Delete the .JSON file AND .LOCAL folder
  4. Uninstall / reinstall Studio
  5. Restart my OS

My license is not expired, I can open / create new workflows with no problem. Any help would be much appreciated.

@ZainLS
I had the same problem once. I rebuild the whole page from scratch. So if there is a solution to this, that would be nice.
Else, the solution would be to rebuild that page :stuck_out_tongue:

Thanks for the prompt response! Ideally would like to avoid rebuilding as this build is time sensitive.

Any idea what caused the error so I can avoid running into it again assuming worst-case scenario of a rebuild?

With me it happened when I moved the folder. All other files worked fine tho.
Do you have something like a load-balancer or some dynamic value that is changing somewhere in your workflow?

No load-balancer, but yes I had dynamic variables that would increment as they would loop through various iterations of the workflow.

Good to know, were you working on a virtual machine?

Hmm no Thats not the issue i think. Is it just 1 file in your workflow? or Main?
Did you try: go to Outline pane and select the old activities, then copy it to the new flow char.

Else i dont know :frowning: Maybe a expert can help you.
GL!

@MickeyFireMouse yeah I didn’t think so either. Correct; just main. Problem is in the outline Pane I can’t see any activities.

Thanks for all your help!