Workflow does run from UIRobot but is stuck in pending state when run from orchestrator (same robot)

Hi! I published a robot to orchestrator. It is available to create jobs, and I’m able to run it from UIRobot, but when I run it from orchestrator, it gets stuck in a pending state. The robot used is available. I have no idea what to do and didn’t find any solutions on the forum. Thanks for any help!


hey @christophe_desseaux
could you provide more information on where the process starts to run into a problem? Are there any Log Messages created during the Job or is the whole Log of the Job empty?

Regards Bob

Hi, when running from orchestrator there are no log messages, the job doesn’t appear to start:

when running from UIRobot, it runs smoothly and log messages are generated:

Regards,
Christophe

Hmmm hard to say… When you don’t stop the process you don’t run into an error? It just stays pending? How long did you try out?

the job i created just now has been pending for about 20 minutes now.

ok, this is going nowhere.

Could you add the Domain in front of the User Name? Like YOUR_DOMAIN\christophe.desseaux
I think he is confused because of the point in your username… but its just a guess

Try the NTBPE03SKF\christoph… Username from the working Job

Hi.
This is usually caused by a licensing issue where Orchestrator thinks all the robot licenses are used up, therefore it doesn’t start until a license is freed up.

I would first suggest, Filtering your Jobs by Running and all days to make sure nothing is running. Then, I would suggest going to “License” under the menu in top right corner (where the orange circle is). On that screen, you can click on “See More” under the licenses that you are using. This will list all the Robots and Machines and tell you if there are any available. Ideally, you want “Runtimes” to be equal to “Robots” number, and “Used” should be on 0 if there are no jobs running.
image

If you see licenses being “Used” even though they are not, then you will probably need to restart that machine.

I hope this helps.

Regards.

1 Like

Oh also, if you are using for example NonProduction and it says “of 1” or “of 2”, and you have have more robots than the licenses you have available, this can cause a licensing issue. In this scenario, you would need to probably remove the Robots and recreate them to resolve issue.
image

Like for example, we have a situation where we have 2 NonProduction licenses on one Orchestrator, but 3 Rboots. Well, it got confused and tied the 2 licenses to 2 of the 3 robots. So, the 1 robot where the license was not tied to, it would not run and just go to Pending state. — we would need to log off or delete that 3rd robot so the license could connect to the correct 2 robots. It gets complicated :stuck_out_tongue:

Regards.

This is how it looks. I am using community edition version 2019.2

Capture

I have 1 env, 1 machine, 1 robot and 1 process…

Hi Bob, adding the domain seems to have solved it. They’re running now. Thanks!

Nice, glad i could help. Please mark my Answer as Solution thanx!

@qateam
Seems like a bug, job should fail if it can’t authenticate.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.

It’s been spotted and will be fixed.