Workaround to install Chrome extension on Chrome 73

Please be aware of the fact that the latest Chrome update v73 broke compatibility with our UiPath extension and you will not be able to install the extension anymore directly from Studio. :roll_eyes:

Users who have the extension already installed should not be affected.

For everyone else, please use this workaround to get it properly installed (under “Extension Fails to Install After Google Chrome Update”):

We have already included the fix for this issue in the 2018.4.5 patch release for Enterprise Edition and the 2019.4 release for Community Edition (which is now available via our Beta channel).


Thanks @loginerror! A much important update :slight_smile:

This workaround did not work

1 Like

Hi Jay,
Can you let us know if you’ve followed both steps and are still not able to see the extension installed? Both steps detailed on the guide and copy pasted below are required in order for the extension to work.

The Chrome extension needs to be installed, as follows (both steps are mandatory):

  1. From Studio, as explained here . This step ensures that the Chrome Native Host component is installed, which enables communication between Studio and the Chrome extension.
  2. From the Chrome Web Store. This step installs the Chrome extension.



Worked for me thanks, it wasn’t working at first then I just restarted chrome


Thanks and it helped me in successfully installing the extension.


Hi Catalin

Yes I followed both of those ways step by step. I also uninstalled both chrome and uipath and reinstalled both and then tried again.

Uipath studio still will not work on Chrome

Kind Regards



Could you please check ‘UiPath Web Automation’ extension.


Hi Jay,
May i ask what version of Studio and Windows you are running? Would like to try to reproduce this on our internal enviroments.


1 Like

Hi Catalin

I am running Windows 10 Pro

And Studio

Will this affect enterprise version : 2018.4.4 of uipath

Hi @MariaJosephina

Unfortunately yes, but only for new installations. However, we’ve already released the patch 2018.4.5 which fixes the issue.

1 Like

Hi Catalin

Here is an error I receive from the uipath extension

Not sure if it helps?

Kind Regards


Hi @JayEff

Could you add your version of Chrome (from Chrome about page) and the currently installed UiPath extension version?

Hi guys, is it possible to use chromedriver instead standart browser to ensure the realiability?

Version 73.0.3683.86 (Official Build) (64-bit)

For Chrome


For UiPath

Hi @JayEff

Could you check this registry key and provide it’s values:

Something must be going wrong at the 1. step of the guide (installation from Studio).

1 Like

1 Like

Has anyone gotten this working? I have the same issue in 2019.4 beta. I need Chrome support for a POC for my company.


Inspect highlights entire Chrome control rather than elements.


  • Chrome: 73.0.3683.103
  • UiPath Community Edition: 2019.4.2
  • UiPath Chrome Extension: 9.0.6821
  • Windows: 10.0.17134 Build 17134

Steps To Reproduce

  • Create a Find Element activity.
  • Click the ellipsis for its Selector property.
  • Click Indicate Element.
  • Mouse over a Chrome window.
  • The entire browser control is highlighted.
  • Click.
  • UiPath shows the error that the Chrome extension is installed but not enabled.


  • Chrome extension installation from UiPath
    • Installed Chrome extension from UiPath backstage per instructions in this thread
    • Enabled extension
    • Enabled all extension access:
    • Rebooted computer
  • Chrome extension installation from Chrome Web Store
    • Same as above but reinstalled extension from Chrome Web Store
  • UiPath beta
    • Switched to beta per instructions in this thread
    • Confirmed download had finished and version had updated
    • Rebooted machine
    • Installed, enabled Chrome extension per above

Please use the below Link