With FTP Session Activity error while uploading file

I am running into a error while trying to upload files to an FTP server using the “With ftp session” activity. Downloading seems to work perfectly, but when I try to upload there is usually an error if the file is is large in size (around 4GB). All the connection properties have been correctly configure for the FTP session.

Here is a screenshot of the exception:

Hello @farzan.al-hafiz!

It seems that you have trouble getting an answer to your question in the first 24 hours.
Let us give you a few hints and helpful links.

First, make sure you browsed through our Forum FAQ Beginner’s Guide. It will teach you what should be included in your topic.

You can check out some of our resources directly, see below:

  1. Always search first. It is the best way to quickly find your answer. Check out the image icon for that.
    Clicking the options button will let you set more specific topic search filters, i.e. only the ones with a solution.

  2. Topic that contains most common solutions with example project files can be found here.

  3. Read our official documentation where you can find a lot of information and instructions about each of our products:

  4. Watch the videos on our official YouTube channel for more visual tutorials.

  5. Meet us and our users on our Community Slack and ask your question there.

Hopefully this will let you easily find the solution/information you need. Once you have it, we would be happy if you could share your findings here and mark it as a solution. This will help other users find it in the future.

Thank you for helping us build our UiPath Community!

Cheers from your friendly

Hi, @farzan.al-hafiz Could you please specify which application you have used for FTP server setup (I am assuming it’s Filezilla). Did you check any specified timeout has been put. There is no max file size limit on the server-side. Upload fails not on Server side bud somewhere between in router/firewall/antivirus/computer. Problem is that the FTP program does not understand when to use the proper APPE command and uses STOR command instead (the last command will start overwriting that file not appending), as the so-called “control session” drops/fails.

As a solution, you could try:

  1. For testing – change max allowed connection in FileZilla to 1.
  2. On Windows machines one could try the WinSCP program and on Mac – CyberDuck or from command-line “SCP” program.
  3. Request you server administrator and make sure the server can resume large files.

I am getting this error when trying to connect to sftp. The connection works when tried with FileZilla.


With Ftp Session: The argument of type ‘System.Boolean’ cannot be used. Make sure that it is declared on an activity.

I was getting the same error. I though the error would come from the port, host, firewalls, etc. but it actually came from the password. I was just trying to convert the secure string from the credential to string, but not doing it properly. Therefore it couldn’t create the connection.

Used this and the error got solved:
String plainStr = new System.Net.NetworkCredential(string.Empty, secureStr).Password

Sharing in case someone is clumsy as me :slight_smile: