Windows legacy and URL and Xpath activities

So i tried using webpath scrape activities in the uipathteam.xpathwebscrapeactivities package, but it said it wasnt compatible with windows projects

Then i tried to use a simple “htmldocumenttest = web.load(html)” and it told me that needs a reference to system.private.url. … which wasnt compatible with windows projects.

Surely these basic Html / web functionalities must be avilable on UiPath new projects as well as legacy projects? Am i doing something wrong. Or missing something ? Is there another way to do this?

Steven.

@steved

It seems like you’re facing compatibility issues with UiPath and the packages you’re trying to use for web scraping. UiPath is designed to be versatile and compatible with different types of projects, including legacy and newer projects. However package compatibility and dependencies can sometimes be tricky.

Ensure that you have the necessary dependencies and packages installed.
Make sure you’ve selected the appropriate project type.
You can use activities such as 'Open Browser,Get Text and Click to interact with web elements.

1 Like

Thanks for the response.

Im trying to do things by getting the entire html from various sites.

And parsing with xpath or other methods.

And these dont seem to work due to the lack of package compatibility in the new “windows” as distinct from windows legacy frame work.

If you cant use the two packages i just cited, one of which is really extremely basic, i imagine theres TONNES of functionality unavailable in UiPath “windows” version…?

Steven

surely UiPath will be losing a LOT of users due to such incomplete functionalities?

Steven

If i want to create a new legacy project, can i? Or has that option been prematurely ended now?

Steven

In general have a look here:

1 Like

If you need to perform web scraping and parsing HTML content, it’s often recommended to use the “Web” framework rather than the “Windows” framework.

I of course already have that installed but perhaps i need to study it more to get more out of it without using other packages.

thanks ppr.

Steven.

I think im distinguishing between windows and windows legacy type projects. IS there a third type called “web”? How do i use the “Web” framework?

steven

When the author of a particular author decides not to offer a package for

  • Windows Compatibility
    OR
  • Stops its support for Legacy

we cannot force.

In such case we recommend to check what will be the best option for

  • the next close time
  • in general

As we can expect, that UiPath Marketplace / other Nuget Packages will be on the present .Net Levels we can also expect the trend to phase out Legacy

When working directly with HAP (e.g solving the case or creating the own Custom Library) is an option, then we can also help for setting up the same functionality as Code Statements

For the migration Topic in general - the Landing page:
[InfoSet] - LegacyToWindows Migration # Information Index - Help / Something Else - UiPath Community Forum

1 Like

@Dilli_Reddy I don’t know how to access the web framework.

Is it a framework like Windows and Windows legacy…?

// From Web
var url = “http://html-agility-pack.net/”;
var web = new HtmlWeb();
var doc = web.Load(url);

From the htmlagility website, This very simple code seems to be impossible without the system.private.url package…

Is there another way to use it without the reference?

Steven.

when the project is set to windows it can happen that this is complained by the Compiler

Close XAML
Take a Backup from the xaml
Open XAML in text editor - notepad++
Add the following line:
grafik

 <AssemblyReference>System.Private.Uri</AssemblyReference>

Save and close the editor (notepad++)
Open it again in UiPath

At our end it was working and we were able to work with HAP

Ill give it a try later. Thank you so much for trying.

Also keep in mind that we have
grafik

OK That notepad method gve an initial error on reopening in UiPath but it ran in debug mode just fine.

Ill take a close look at that activity. Thank you so much for your efforts.

:+1:

we recommend to use notepad++ and not the Windows text editor.

What was used at your end?

I used notepad but i can go back and do it again in notepad++ and see if it improves anything including specifically the error message on opening UiPath studio.

But even with windows notepad it already worked. How is the difference significant?

OK i did the same thing all over again (with notepad++) and no red error on opening UiPath with the inserted line this time :grinning::+1::+1:

Id love to know why the difference.

Steven