Windows Application Select from Dropdown

I am interfacing with an older windows applications and having issues selecting an item from a dropdown. The best luck we have had was using a type into but if it doesn’t type fast enough it will select an item from the dropdown that is incorrect. We have tried a number of things including select item, the CV activities, trying to paste value from clipboard. Any other suggestions?

Hi @botman

Try changing the UiAutomation from Default to AA using F4 keyboard.

Suggestions:

  1. Click on drop down to display dropdown menu values
  2. Delay 2 to 3 seconds or more - to allow dropdown menu control to load and display values
  3. TypeInto (down arrow) or (value)

For TypeInto (value) you need to test if older windows controls supported type into action for dropdown menu. Otherwise you have to revert to down arrow to select your desired value.

@GreenTea - Tried the approach but still facing the error.
While we do a type into it would select the dropdown values based on each character been typed.
Ex →
if Typeinto = 401CCAGRD1
By the time the BOT types 401CCA, it would have selected the first matching record, so the BOT ends selecting 401CCA9200 (401CCA9200, is one of the drop down values) instead of 401CCAGRD1.
Any other way we could handle this scenario???

Hi @maheshnag.b

Thanks for the updates. Please try one of these two workarounds

  1. TypeInto activity, enabled SimulateType to True
  2. Set Text activity