Wildcards in filter get out look


#1

How to use wildcards in filter option in get out look mail
i want to retrieve mail which has keywords like Application and Cancellation


#2

Here is the approach.

Inside For Each You can use if condition and pass this (item.Subject.Contains(“Application and Cancellation”))


#3

i want it in filter option of get out look
"[Subject]"=“Application and Cancellation”? is this possible


#4

Using wildcard characters in message rules is not supported unfortunately.
Only way is right now to iterate it.
Partially. In current implementation only strict filters (no wildcards) can be made

Look into this thread : How to filter messages in Get outlook mail messages


#5

I tried it didn’t work for me so i choose to use conditions.
Please refer this.


#6

i tried this it didn’t work for me too


#7

What did not work for you? all applicable filters works.


#8

i want unread mail’s which contains keyword application
in filter option of get out look


#9

Hi @shruti

In current filter property implementation, only strict filters (no wildcards) can be made. I would suggest you to, iterate through the list and inside if use the function contains.
You can search other topics on the forum as this has been already discussed a couple of times.

Regards
Vitan


#10

Hi All

For Filter on Subject i have added below Line and its working for Subject

“@SQL=”“http://schemas.microsoft.com/mapi/proptag/0x0037001f”" like ‘%Offboarding%’ "

but its not working with two conditions one for Received Date other on subject

“[ReceivedTime] >= '”+now.AddDays(-1).ToShortDateString+"’ AND [ReceivedTime] <= ‘"+now.ToString +"’ and @SQL="“http://schemas.microsoft.com/mapi/proptag/0x0037001f”" like ‘%Offboarding%’ "


#11

***Filter on Get Outlook Mail Messages is working with below lines(Subject and ReceivedDateTime)

“@SQL=”“http://schemas.microsoft.com/mapi/proptag/0x0037001f”" like ‘%SubjectFilterValue%’ And ““http://schemas.microsoft.com/mapi/proptag/0x0E060040"” >= '”+Date.Now.Date.AddDays(-2).ToString(“yyyy/MM/dd”)+"’"


#12

First one wasnt working because of mixing Jet and DASL syntax.
A couple of months back DASL wasnt working properly, seems its added now.
@adrian or @badita could you confirm? It would help to know what’s the official status on this (and from what package version it should work).


#13

I know i m not offical guy but here i have shared with you :slight_smile:

Regards…!!
Aksh


#14

Thanks mate :slight_smile: