Why "UiPath Stopped Working" error on Read range?

I am getting “UiPath Stopped working” error when reading data from an Excel sheet.
I kept getting the same error, and it crashes. First it freezes for a long time, and then it gives an error like the following:
image

When I click Close program, I get the following window:

image

What is annoying is, I have this Read Range inside Try Catch, but it doesn’t even prevent the robot from freezing (not really freezing, but the robot remains idle) for like 30 seconds to 1 min, and it doesn’t even catch the exception. Then the entire program stops.

I first thought the Excel sheet had too much data, but that is not the case.
I even tried just reading one row and it still returns the same error. The only unusual thing I see in the excel sheet is, when I open the Excel file itself, I get this popup:

and when I click on some cells on the sheet, I get the following popup:

Is this the cause of the issue? Unfortunately, I cannot unprotect the sheet without the password, which I cannot ask my customer for until next week. If this is the cause of the error, I could wait, but if it is something else, I would like to fix it this week.

Can anyone help me please?

Hi @tomato25

This is the most likely cause of the issue. It appears to be an issue with the memory be faulty do to the mentioned infinite loop.

2 Likes

The thing is, this sheet has about 60 rows, and more than half the cells are “protected”.
Like when I open the sheet, and click on some cells, I get “The cell or chart you’re trying to change is on a protected sheet” message.

But some cells can still be read without any issue, using Read Range activity.
But some other cells cannot be read, and it freezes and crashes. This is so confusing, and annoying.

1 Like

Circular reference = robot reading and rereading the same cell infinitely?

1 Like

oh wait, so the problem is not the protected sheet, but the circular reference?

Does it even affect Read Range?? I thought Read Range will not consider the formulae written in each cell, and just read whatever the cell actually displays as data?

What versions of tools are you using? (Studio and Packages)

1 Like

I tested Read Range inside an Excel Application Scope with password-protected, unselectable cells as well as password-protected workbook and file. It had no problem reading the cells (as long as I provided the password in the Excel Scope properties). Issue must be with the circular reference of your workbook…

1 Like

I am using Community Edition 2019.7.0 and packages in the following

This Excel file is from the customer, and I cannot manually edit it…

Is there any way to get rid of all formulae from all cells in the Excel sheet, using UiPath?
I mean, circular reference means there are cells that are depending on each other’s formulae, correct?

Anyway you can save as (Export) a CSV and use the Read CSV activity to get the data?

1 Like

Do I have to Save As manually though?

And does Read CSV and Read Range make any difference?

Btw, I just checked the CPU usage and it got quickly up to 100% as the program started reading Excel sheet…

I just enabled Circular Reference, and the popup disappeared. But I still cannot Read Range it.
I guess, I need to completely get rid of the formula from the cell where circular reference is happening, which I cannot do without the password…

Converting it to a CSV should get rid of the formulas (and protections) and the file will just be raw data that can even be opened in Notepad. The cells will be delimited by commas. Read CSV is done without the Excel Application Scope. It also reads the CSV in the background. The output is still a datatable.

The limitation with this method is that can only be converted to CSV if there is only one sheet. And Read CSV reads the entire sheet rather than a selected range.

1 Like

Hmmm, this Excel workbook has 5 different sheets with similar structure…
This won’t work…

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.