Why the assistant gets activated every time a process is scheduled to run

this is super annoying, can someone tell me how to stop it from jumping to the front?

Hey @lynnsong986,

Is the process scheduled to run on the same machine, and is it set to attended or unattended mode.
Because assistant helps with running attended automations.

it did that when an unattended process is run

sorry forgot to mention this only started to happen after I installed the latest update this morning and the assistant jumped out when the triggered process was run even when it was not open

ok had to go to assistant properties to change the window to minimized

it still does it even though I disabled it and minimized the window in the properties

Hi @lynnsong986 ,

Could you also mention the version to which it was updated ?

Also, Is the Automatically Start Assistant option disabled ?

This option might not be one that we are looking for, But you could check with disabling it if it was enabled.

it is the latest version, 2023.2? I got the notice to update this morning

the Automatically Start Assistant option is disabled when this happens…


I have a few questions:

  • How is Assistant connected (Service URL or Machine Key)?
  • Assistant is minimized in tray or in taskbar when this issue appears? Or is completely closed?
  • Your process run successfully or it fails?
  • How do you start the process? From Assistant? From OR?
  • Do you have in Automation Ops, in Assistant policy, this option enabled?


the Assistant is connected through service URL, it is completely closed when it happens (in the properties I have the screen set as minimized). the processes ran successfully. these are unattended processes scheduled with triggers in OR.

where can I find that option?

thanks for your help

Hello, @lynnsong986
The option “Minimize Assistant while a process is running” can be one solution to resolve this and can be found in two locations:

  • Automation Ops. Access the cloud → Automation Ops → Governance → Choose your product policy → Feature Toggles and set yes to this option of minimizing Assistant while running.

  • Another way to achieve that → you can search for the agent-settings.json file located in %userprofile%\AppData\Roaming\UiPath and (if you don’t already have it) add the defaultNugetWidgetConfig property under the agent tag; Here add "minimizeWhileRunning": true (and also expire property as this is mandatory) → All the needed information and indications here.
    :warning: Keep in mind that if you already have a policy in Automation Ops, that policy will overwrite this file.

:white_check_mark: The easiest solution would be to completely quit the Assistant, as the close button (X) only minimizes the Assistant to tray (you can see that the icon is still available in the tray if you only close it - X). To quit it, simply right-click the tray icon and select Quit.

Please tell us if this resolves your problem and thank you for reaching out to us :rocket:

Thank you so much, really appreciated.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.