Why resolution screen not 1920 on 1080 ? Unattended robot

hi!
In robot settings I set resolution 1920x1080 and in ProgramData Uipath.settings write this resolution and depth 32
But when run unattended robot resolution is small.
When I run proccess from studio on this server all work correctly.

It sounds like you’ve done all of your due diligence. It seems like it should be working.

Here’s one thing I can tell you. Often window maximization is achieved by sending a CTRL+ SPACE + X, but the space and X must happen with a small time delay between them. If UiPath is doing the maximization that way behind the scenes there’s a chance the micro-delay isn’t happening.

Possible workaround?

Here’s what I’ve done to make sure UiPath maximizes windows. At the start of my programs I add a Send Hotkey activity that sends a ALT+SPACE+X command. In fact, I’ve been known to do it twice just to make sure it’s done.

Here’s what it looks like in my UiPath project:

This doesn’t really fix your issue, as it seems like you have done what’s needed. But it does offer a workaround you can try in your UiPath project.

1 Like

Thanks, but it is not solution.
System.Windows.Forms.Screen.PrimaryScreen.Bounds show resolution is 1024 on 768, but robot settings is 1920 on 1080 and in Uipath.settings the same.

If you have the LogonToConsole set to True, it will use the console’s resolution which is the resolution of the monitor that is connected to the physical machine. In many cases, this results in a 800x600 resolution, but I suppose it could also get you the 1024x768

So, typically, you would want it set to False, assuming it isn’t already.

There are also two places to set the resolution used by robots: 1) in the UiPath.settings for the robot machine and 2) in the Robot settings in Orchestrator.

3 Likes

This is one of the most fascinating answers I’ve ever read. If you’re not certified you should definitely consider it. And if you ever need a tutor (but you probably wont) I’ve got you.

Just adding onto the correct answer by @ClaytonM with an image.

2 Likes

LogonToConsole will be set to False, I not edit it.
Resolution on server is 1024 on 768. I see this by command:
wmic path Win32_VideoController get CurrentHorizontalResolution,CurrentVerticalResolution

And the robot will not be able to reinstall on its resolution from settings?

Did you set the Resolution in the Robot’s setting in Orchestrator as shown in @cameronmcnz’s image? I always set it to 1920 w 1080 h 32 d with LogonToConsole checked and set to false.

Also note that if you are remoted into the machine from a laptop display, by default, will use your laptop’s resolution. If the Robot connects to that same rpd connection then it will use whatever resolution you are signed in with, so I suggest signing off of the robot, if this is applicable to your situation. To sign off of rdp, use Ctrl+Alt+End

Let us know if that is helpful.

1 Like

this is Uipath.settings in programData on server:
image
this is robot settings in orchestrator:
image

and after start job resolution 1024*768 (I write in log command:System.Windows.Forms.Screen.PrimaryScreen.Bounds.Weight and Height )

Yeah, in the robot settings in Orchestrator, you need to check the ‘Login To Console’ then select ‘No’. Right now, it’s using the default which you show as ‘true’.

yes, it work’s, thanks!

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.