Why is there STILL no way to delete an In Progress Queue Item?!

@jeevith @otico Thanks for the helpful Code!

Please mark this as a Solution to this thread as long as there is no “official” way to deal with it. @postwick

I’ll consider it solved when there IS an official way to do it.

I agree with @postwick

Business and Support teams should be able to manage this through Orchestrator like everything else. They can’t/shouldn’t write code to do this.

If you can add queue items through Orchestrator, you should be able to remove as well.

This is totally unaceptable… perhaps you have checked if that user is a paying customer, and maybe he is not, but he can be working in a company that have paid for UiPath licences. Anyway… paying or not you should receive any critic about the product always as a opportunity to improve it.

I can’t either understand why we should wait 24 hs for a “in progress” transaction status to become “abandoned” in order to perform whatever we want to do with our data.

Same thing with the restriction of selecting a robot in queue triggers.

Hey Daniel,

I agree the in progress thing is visually unappealing. Perhaps an explanation on why it just gets stuck there would be helpful for end users to understand (since even if you restarted the process in Studio, those in progress items don’t get picked back up ever again)

Your note of selecting a robot in queue triggers has been corrected in Orchestrator 21.4.0 (latest version recently released) to some degree:

You can add multiple user/machine pairs per job for 1 single trigger. (If you add three pairs, you then will run 3 jobs on those 3 robot users and the applicable Machine(s))

Making it so complicated wasn’t a good solution for the queue triggers. They need to just make it work the same as the time triggers.