Why is my bot working perfectly in Studio Debug mode - but has all kind of different problems when run through Orchestrator?

Hi guys,

so I have such a weird problem and I’m very scared cause I have to bring this online for a customer.
It’s basically a default UI Automation project that uses a custom made application. When I run the project in UIPath with Debug or Normal Mode it works perfectly.

When I publish it to Orchestrator and run it on production I get all kinds of weird problems:

  • Sometimes it doesn’t find an element although it’s there and doesn’t click it ==> Then it can’t find the next window
  • When it tries to kill a process I get the error “No permissions” and then the bot closes

Why is it behaving so differently on the production machine when run through Orchestrator? That was not the first time this happened to me. This machine is configured 1:1 like my development machine.

I would love to hear some tips and guidance from you guys. Thx so much.
Is there any way to “debug” it on that very machine? Or is it bad practice to open the project on the productin machine in UIPath and Debug it there?

a common trigger of the need to better synchronize the bot with the application


With the issues you are describing I would go ahead and look into debugging it in the production environment. Yes this might be considered bad practice but at the end of the day we are working with front-end automation which means small configuration/gpo differences can impact performance.

Try to ensure that your selectors are 100% reliable and use modern activities with verify execution.

Best regards

also have a look on this:

@ppr @lavmang

Thank you so much guys. So I pulled the project in UIPath on the prod machine and found some problems (I had to wait for app element a bit longer).

But now I have another problem. I can’t kill the programs process I always get “no access”. But on the dev machine it works. The robot account that is executing the robot has admin permissions on the machine and I can kill the process manually with task manager.

Here is the logic to kill the task:

So basically I look for all tasks with “myprogramm” in it’s name. Then loop over all found tasks and kill them. But in UIPath I get the “no permissions” error when that specific logic runs:


Zugriff verweigert means “no access” in english.

Any ideas? (on the dev computer it works).

checkout following:

  • bot executing account is the same that you checked for the permissions
  • process belongs to the particular user representing the running bot session

To both yes. I solved it by checking continues on error
It doesn’t bring a error now and also closing the application. Weird error if you ask me.
Thx so much for your help