Why I am getting unnecessary character underscore (_) from a text block value in abbyy flexicapture setup station

Find the screenshot of actual field and its extracted value-

what is going wrong here, why these underscores are appearing here. can any one suggest any solution?? Cant use replace here.

Field settings-

Batch settings-

Hi,

In the data tab, go to autocorrect settings and go to edit character and replace _ with null and make it fuzzy match and try, it will resolve the issue or you can click on use script and write a script in your preferred language to remove anything other than characters and spaces.

Let us know if this helps.

Regards,
Pavan H

Hi Pavan,

I tried with following settings but its not working. Take a look at the settings-

I went to Data tab => Auto Correction => Replace Text. (I also looked at Replace Characters option but there is no radio button to set Fuzzy Search). So I tried it with Replace Text option. See the attached screen shot

Hi,

Enable the use script checkbox inside the autocorrect settings and use the following script, the script is javascript language.

var val=’’;
for (i=0;i<this.Text.length;i++){
if(/[0-9A-Za-z\s]/.test(this.text.charAt(i)))
val = val+this.text.charAt(i);
}

This will help you in fixing the issue with anything other than alphabets, numerics and spaces.

Hope this helps.

Regards,
Pavan H

hi pavan,

see this screen shot-

here space between words has also been replaced by underscore, so now if we replace underscore with anything than it will replace all underscores. Then at end you get a single word of result. This is the big issue with replacing underscores here. Any other solution.

After applying JS code u suggested, I got this output- TheBankintheLittleGreenTrailer

spaces have been removed as it was underscore earlier.

Hi,
Try changing the text type from advanced to ocr and then marking type to None and remove the one line property.

Try to play with these properties and you will get the result.

let us know if it works.

Regards,
Pavan H