Why does my automation keep resulting in system exceptions?

Hello everyone,

I am having a hard time determining what is causing my automation to result in system exception (fail) for an unattended bot automation. I have examined logs and screenshots thoroughly but still cannot determine the problem. I suspect it is an environmental issue (environment is slow, on-screen items not rendering on the screen, etc.) but am not sure. One idea I had was to instruct the robot to open a video recorder at the very start of the automation and then save the recording at the end of the automation but wanted to get ideas from the community first on how to determine what is causing my automations to fail. Your help is appreciated.

That’s exactly what I use as last resort. Or Robot Streaming

Cheers

1 Like

Hey there J0ska. Thanks for helping. I spent like 2.5 hours trying to get your solution to work. I tried a bunch of different port numbers by editing the config file. Also, I am launching the .exe file by having the robot launch the .exe file from the RUN window. I tried different browsers. Here are the result I get when trying to run in Chrome and IE. Not sure what I am missing.

1/ It doesn’t work in IE. I ony use Chrome.
2/ As stated in the doc both broadcaster/robot and receiver must be “in same network/domain”. I guess the author means the same IP subnet - at least this is my experience

3/ You could troubleshoot it by broadcasting and receiving on the same machine.
You should get something like mirror in mirror:
image

4/ Another troubleshooting option is using telnet

telnet “robot’s IP” “port”
e.g. telnet 192.168.0.1 8080

Cheers

Hey there. Thanks for getting back. I am getting the mirror in mirror image when I try to watch the live stream on the same machine. So watching on the same machine works. However, I am still not able to view from another machine that I am pretty sure is on the same network. I took screenshots of the IP addresses for both machines and compared them.

Also, I tried using telnet as you suggested with no luck. Maybe I am using the telnet command wrong (please see image).

1st Image - IP address of machine used to view the live stream
2nd Image - IP address of Robot machine
3rd Image - Using Telnet

using telnet

You should start telnet from CMD prompt (like ipconfig).
In your case it should be

telnet 10.150.19.211 8080

Cheers

Just a follow up. I got it to work for my project and we are currently using it to trouble shoot problems and it is very useful. However, we got it working by entering the following url format in google Chrome that contains the IP address of the machine streaming the robot followed by the port number: http://99.999.999.99:8080

Thanks again!

1 Like