Why do my activities have less options/different image than in the tutorials?

Hey there, I am currently doing the developer foundation course and I am struggling following the tutorials. The reason is that in the tutorial, the activities chosen have more options in my design view.

Missing Activities

“Build data table” for instance has the option “DataTable” option, which is missing in mine. The image of the activity is also just a grey box with black arrows, instead of a stack of coins with a little table.

The same applies to the message box, the RegEx activities, and many more. This is quite difficult because it means I cannot open the additional features such as the RegEx wizard. I can only edit the options in “properties”.

I have been trying to search for an answer, degraded to version 19.7 (when the tutorials were made). But nothing helps. Can someone help me?

Hi @Myrthe,
Are you able to attach example project so I could check it on my end and see if I can replicate this. On which exact version do you see this behavior? Are there any orange or red information in output feed?

Hello Pawel, thank you so much for your help! There is no exact project in which it happens, it happens in all my projects, unfortunately. I noticed it mainly happens to activities in UiPath> Core> Activities> … , see image:

To give an example, I attached the Acme demo. When I open it, I see something else then displayed in the video. Here the tutorial has the option to set the level as a dropdown, and I do not:

My screen:


UiPath tutorial screen

This is the file: Main.xaml (19.3 KB)

About the version I am using:

  • I use the community offline edition of Studio
  • I have a community license
  • UiPath.Excel.Activities v2.9.5
  • UiPath.Mail.Activities v1.9.5
  • UiPath.System.Activities 20.10.3
  • UiPath.UiAutomation.Activities 20.10.8

I really hope we can find an answer because it would make following the training a lot more pleasant!:slight_smile:

One more thing I would ask you for. Is the same happening for the new projects?

Hey Pawel, sorry for my late reply. This happens to all projects I run, so both projects I download from UiPath (given in the tutorials) as projects that I create myself. Does it have anything to do with my community version?

@Myrthe could you please try restarting Studio? I think I’ve seen this behavior once or twice before and, if I remember correctly, a Studio restart fixed it. I’ll search for the previous bug report and file one if it’s not already there.

1 Like

Also, Studio logs would be very helpful if you could provide them, @Myrthe.

Thank you @Tudor_Sandu for your help. I have restarted studio multiple times and currently, I even reinstalled it on a different laptop. The same behavior perseveres.

Furthermore, I do not understand what you mean by logs. Because my Studio does run fine there are no error logs. It is just the options that are missing. For instance, when I select the “select file” activity, I do not have the possibility to set a location to find the file.

@Myrthe open File Explorer and go to %localappdata%\UiPath\Logs (by default, that should point to something like C:\Users\your.name\AppData\Local\UiPath\Logs).

There you should find some files containing a date in their name and having a .log extension. Select those from a date when the problem happened (e.g. today), make ZIP archive and send them over, please. You can do it in a private message to me if you want.

Thanks!