While running process from System Tray, which value should be taken for input arguments?

I have an observation; not sure if i am doing incorrect here; please clarify if possible.

I just added MessageBox into a Sequence which do multiplication with a argument and display the result.
here, I have added an In_Argument (e.g. in_A) and defined Default value as “15”.

Into the MessageBox:
"10 times of “+in_A+” is: "+(Convert.ToInt32(in_A) * 10).ToString

Now,

  1. If i run the process in studio, it gives the result "10 times of 15 is: 150
    That is correct.

  2. If i run the process from Orchestrator and provided 25 as Parameter value for in_A.
    It gives the result "10 times of 25 is: 250
    That is correct

  3. If i run then process from Job and provided 35 as per job parameter for in_A.
    It gives the result "10 times of 35 is: 350
    That is correct.

  4. However, when i simply run the process from System Tray icon (UiPath agent)
    It gives the result: "10 times of is: ".
    Which seems incorrect here.

Am i doing wrong?
or if not, what could be expected result here, either it should take default value from Studio or it should take a value defined at Process level?

@gopal_1981

We can’t have any option to pass input parameters to our process which is running from UiRobot system tray. That’s why you are not getting any output.

Instead of that use one Input Dialog activity in your process. When you run this process and it will prompt dialog box to enter input.

Thanks @lakshman for reply. I was just trying difference cases for parameter passing.
Don’t you think so, it should consider default value which is mentioned in Studio?

1 Like

@gopal_1981

Yes if you not specified value then it will consider that default value only.

Thanks. However, it’s not considering the default value. That’s the reason i started this thread.
I wanted to understand if you find same behavior or i am doing something wrong?

I’m with you here, it should get the default value from studio, but if you need this, then at start of process, you could put an IF condition to verify the value, if it is Nothing then assign it manually to 15.

Thanks.
Yeah, there could be different workarounds like @bcorrea and @lakshman mentioned here.
So, can we say that it’s a defect in UiPath here? :thinking:

1 Like

I mean if you are sure this is happening to you, i would say it is a bug, but i run here a test that seems normal and default value worked fine from manual process run in CE…