Which activity will make orchestrator thinks that the workflow is not for unattended


I published a package and in the orchestrator, it seems like the orchestrator thinks that my workflow is for the attended one as it don’t allow me to choose the unattended bot.

The below are the activity that I suspected:
-build data table
-add data row
-check true
-create html content
-send hotkey (without send window message)
-click activity (didn’t select send window message and stimulate click)
-click image (didn’t select send window message)
-type into (didn’t select send window message and stimulate click)
-type security text (didn’t select send window message and stimulate click)

Which activity is the problem?

Thank you

@g_ii Change input methods to simulate click wherever possible and try again.

1 Like

Can use the Send Window Message ?

Cause some of the stimulate click is not working on the specific element and Send window message can.

Yes. You can use send window message in case

Alright, thanks for your reply, will go to edit the workflow and test it later.


wanted to ask somethings.

I had one item that need to click, it’s a menu and submenu.

When I use the send window message to click the menu, the submenu will appear.
However, when I send the window message to click the submenu, the item is unable to click as the submenu disappear when it wanted to click.

How to solve this??

@g_ii what is the error coming while you are trying to run the project in unattended mode.?

The orchestrator does not able to show the unattended robot when I wanted trigger it with the unattended mode.
And it can run with start process (did show the unattended robot).

That’s why know it’s the workflow problems. As think that maybe it’s something that make orchestrator thinks that the workflow doesn’t support unattended bot.

And currently, I editing all the click activity, click image and type into activity to enable the send window message.

However, I facing problems when I wanted to select the sub menu item.
Initially, I use send window message to click the menu. Then I use send window message to click sub menu.
However, when the activity click sub menu send the message to the application, the menu is close.

And wanted to get any idea to solve this.

(when using stimulate click, show generic error)

If you want to trigger the process,set time trigger,it will automatically run the workflow in unattended mode.

Hi @sangeethaneelavannan1

When I wanted to set the time trigger, the unattended robot is not shows in the specific robot area.

And when I run though the start process via orchestrator, I am able to select the unattended robot and run successful (I did not open the server).

And that’s means that the workflow can run in unattended mode ,the problems is about the trigger’s setting there right?

For the trigger problems,

Create an trigger with other process where it does show the unattended robot area, cancel and again create the trigger for my process, and it finally shows the unattended robot.

Thinking that maybe it’s a bug.



What does this image means??

You can select the robot type under runtime type dropdown and select the machine and host from execution target.

Because the Orchestrator I used is the Orchestrator on premise and it does have this, the Orchestrator on premise will shows the available robot when I select the specific robot.

Thia might help

alright, thanks for your reply, will look into it later.

Hello @g_ii
In the project settings you can enable Attended automation.


I tried to uploaded the package and it shows that it’s unattended process. Thus it shows that all these activity won’t affect and cause the process change to attended.

And since the down part isn’t about the topic. So I will just close here and continue at other thread.


This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.